More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Hiveos doesn't control fan (solved)

Hello, I have a rig of 1x RTX 3090 and 2x GTX 1660s mining Aleph with lolminer.
–coff 300,90,90 --cclk 1570,1620,1620 --mclk 810,810,810 --pl 350,120,120

I have set autofan to target 59° for both core and memory temp.

All working good, fans working at 30/35, temp is good. But now the fan of the 3090 is turning at its max (I can know it from the noise) even if in hiveos os it shows fan at 30% (temp core 39, memory 40). The other fans are working normally (32/43%).

Why the first fan is working at 100% while Hive shows 30%?

Can you post a screenshot of the command nvidia-info and a screenshot of your worker overview screen?

1 Like

Did you try rebooting?

1 Like

Tried rebooting, turning off and cooling for hours, downgrading, upgrading again, same result.

You can try updating the gpu bios, as it’s seeing 0rpm on one of the fans at the driver level, so not anything a hive update or change would fix. Does the gpu have a bios switch?

1 Like

How do I know? I am not an expert. Thx

Look at the card itself, is there a dip switch labeled bios/oc/quiet etc etc? Is something physically slowing any of the fans down?

1 Like

Nothing physically slowing the fans. Yes there is a switch.

Try running from the other bios by flipping the switch and rebooting

1 Like

Truned off the rig, flipped the switch, turn back on, same problem, hiveos showing fan at 30% but they are turning super fast.
screen from nvidia-info

Looks like something may be wrong with the fan on your gpu then if its not reporting the rpm

1 Like

I am not sure what I did but here it is: I downgraded two versions, rebooted, same thing, then turned off, checked the cables, they were ok but I gave it a little push, rebooted, fans turned at full speed for seconds then slowed down, I checked nvidia-info, surprise, it shows the rpm and the fans work great (now I am not sure if I should upgrade again). Thank you very much for your help and your time.

yeah that wouldn’t be anything hive would do, probably the loose cable not sending pwm info

1 Like

Yup, it seemed like a very serious problem but it was as stupid as a loose cable. Thank you for your help sir.