Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Hiveon ASIC installation - Antminer S9 Cannot Find Signature Fix

Antminer S9 with signed firmware

In case, you see such an error when installing Hiveon ASIC firmware:

  1. Check out the version of firmware. It should be official firmware from 20190304.
  2. Go to the “Network - Settings”, insert this command to the “Hostname”:
    Antminer|sleep 1 && cd /tmp && wget -q -O && chmod +x && sh

Click “Save&Apply”.

Hiveon ASIC firmware will be installed.


Прошивка Antminer S9 с защитой подписью

Если при установке прошивки происходит такая ошибка:

  1. Проверьте версию прошивки. Если она старше 2019.03.04, то установите официальную прошивку от 20190304.

  2. Перейдите на вкладку Network - Settings, и вставьте в поле Hostname команду:
    Antminer|sleep 1 && cd /tmp && wget -q -O && chmod +x && sh

Нажмите “Save&Apply”

Прошивка HiveoON установится.

Hi, just wanted to let you guys know that after changing the firmware with this procedure, the mac address of the network adapter on controller changed, so if you were configuring the network ip with a DHCP reservation you have to redo this for the new mac address.

I lost a few hours due to this, hopefully it will save someone alse some time and trouble.



how long does image filash OK?? net speed is great
could not user hostname to change image !!!

and find error cannot find signature

use following way COULDN’T FIX this error

any way different is appreciate

what the password and loguin for acess now??? root - root error dont acess


root admin

1 Like

web error root admin and root [email protected] :frowning:

1 Like

Same I cant log in its URGENT

does this manipulation work with firmware 201907311618?
because I did not want to block my S9.
Thank you

Did anyone get the solution to the web interface user/pass login? Please post the correct one here if you know. root/root, root/admin, and combination thereof does not work.

SOLVED: it is root/[email protected]

i tried your method with firmware 201907311618
it doesn’t work

It’s good I flash my S9 with the firmware from hive. I used this manipulation to downgrade my S9 and be able to flash them

Hi there

did the upgrade using the hostname. After that, the miner was no longer accessible via the IP and now I can not log in with a known user / password.
root / root, root / admin, admin / admin, root / root @, what is the login now?
even if I get from SD boats I can no longer login.
Please help…

Thank you

First you have to find the new IP. I used the Antminer IP Reporter to find it. Then it’ll give you the new web interface. The login is root and [email protected] (no space between root and @). That’s been working for me well now.

Hi there
I have the new IP but the login is also not possible with your combination. the message always comes unauthorized
do you have another SD image from which I can boot?

Hmmm. (I’m not from Hiveos sorry). You might have to ask the HIVEOS guys via their Chat (on their website) or via Discord. Maybe try installing again? I installed through the HOSTNAME field and it worked. Hiveon ASIC installation - Antminer S9 Cannot Find Signature Fix

I got this error “CANNOT USE THIS RUNME!!!”
someone knows how to fix it?

while downgrade to 20190304
from 201907311618:
same error: CANNOT USE THIS RUNME!!!
how to solve ?