Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Hive OS beta no fan control phoenixminer

I’ve just installed an RX 5700, which forced me to use Hive OS beta (0.6-140@200519).
I mine ETH with phoenixminer. I don’t have any fan control, the fans do what they want, which results in dangerously high temperatures.
I’m aware of the “-tt 1” line as extra config argument. This however doesn’t change anything.
This make me suspect that the extra config arguments don’t have an effect on my worker.

Can someone advice please?

Use Hive Autofan feature

1 Like

How did you solve this? I have the same problem and autofan does not work properly. It adjusts fans randomly regarless of temperatures. For example it may use 55% fan speed on 40’C core and 29% fan speed on 45’C core.

1 Like

The autofan feature also takes into account the memory temps on the Navi cards.
So the fans could ramp up if the memory gets hot even though the core may be quite cool.
Could that be your issue?

Work fine for me

Here is without autofan. Note that for some reason, fans are not 40% but 50-52%:

here is autofan settings:

and here are fan speeds with autofan:

note fore example fan control of GPU0 and 3…GPU has higher temps, but fan is 43%, GPU3 has lower temps but fan is 65%

Do I have to use “’-tt 0” in phoenixminer to disable fan control?

I guess you missed report important information

  • Hive client version
  • Autofan settings: Core and Mem Temp Target, Smart mode settings

afaik there is no smart mode settings. Also I have shown image of autofan settings. HiveOS version is Beta2 since AMD RX 5700 wont work in any other version.

Beta2 - it’s version of Image.
Did you update Hive after flashing image or you stiil on client v0.6-140 ?

im still on client v0.6-140. How do I make iso from USB stick im using now to mine? I need a backup if updating will mess up my mining

Update Hive to latest. You will stay on Beta2 Image but will have latest Hive OS GPU client
There was a many bug fixes, improvements including autofan since v0.6-140

Hive web updates not changed kernel, drivers and other Linux internal things. Only Hive client updated.

This was new info, thanks a lot! I thought Beta2 was version which you couldn’t upgrade. Just updated Hive to latest and autofan seems to work! Excellent! Thank you HaloGenius so much for help. :star_struck:

EDIT: autofan still controls temps weirdly, but it seems to work better than last version…


I think we need more informing clients so that they understand the difference between Hive’s image version and the Hive GPU client version.
Hive Image - contains Linux kernel, AMD & Nvidia drivers, some system Ubuntu packages and Hive client of-course.
Hive OS via Web update only Hive client. Such updates fix and improve things such as Autofan, OC, etc …

1 Like

on Hive console (via Hive Shell for example) you can watch how autofan works

blue - keep
green - fan/temp lower
red - fan/temp up

what is the command for viewing this in console?


Ctrl+A+D for exit

I rebooted system and now it wont start mining :frowning:

I remember now updating HiveOS right after I installed this Beta2 image…and it did exactly same thing. Wont mine :confused:

rig booted or no ?

here is the reason:

DM me your rig ID I will look