Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Hit and miss booting

I’m about two weeks into mining on our first rig. It has an Asrock B450 Pro4 MB with 4 × AMD Ryzen 3 2200G CPU, a 1200W Corsair PSU, two Asrock Radeon RX 6800 and one Asrock Radeon RX 6700XT GPU’s.

After all the initial problems of getting it set up and running, it rather annoys me that whenever you change settings for flightsheets or OC’s, etc. it’s sort of a game of hit and miss. The OS seems very unstable. Am I the only one experiencing this?

When rebooting the miner, it takes well over 10 minutes to get is up and running again. Not much fun if changing settings causes it to reboot and each time you sit around and wait for 10+ minutes and sometimes to find that it isn’t loading properly and needs to reboot again.

How do others experience this? We were planning on expanding with more miners in the future, but if keeping things running is exponential to the time needed to just keep this one rig operational, it would become a fulltime job (and the profits are not big enough for that).

hi, are you booting from SSD or USB ? Are you connected via wifi or lan cable ? What version of hiveos ?

My experience has always been ok. I’m on lan cables and all rigs boot from USB sticks. Sometimes there appears to be what i would class as lag whereby you send instructions from hiveos and it could take 20 seconds or so to reflect at the rig end.

Possibly once you are sending reboot command etc something ( running background task ) is falling to shut down nicely and thus keeping the system in an on state.

When you state 10 minutes after reboot do you refer to meaning that it takes 10 minutes or so to even see you rig come back online in hive os or do you mean 10 minutes to actually begin hashing again with your chosen miner ?

I’m booting from USB and using a LAN cable. I’m using HiveOS 0.6-203@210426. It takes about 10 minutes to see the rig come back online. Then, sometimes GPU’s aren’t recognized properly and you have to reboot again.

have you tried to reflash a fresh hive install ? are you able to plug a monitor to the rig and then see whats happening on boot up ?

I have tried a fresh install on two different USB sticks. If I disconnect all the GPU’s, I am able to connect a monitor to the onboard VGA port. Everything seems fine, although it does take a while. Not as long with the GPU’s connected, but still pretty long. With the GPU’s connected I don’t get a connection on the onboard GPU. The GPU’s are mounted where it’s not easy to connect a monitor to one of them.

All in all, HiveOS seems very unstable to me. Change a setting and it’s hit and miss if the rig will start again. I’m not a newbie to computers etc. I also have Domoticz running (in Ubuntu) as a home automation system, with various techniques such as Zigbee, MQTT, Modbus RTU and have even written Python scripts to automate our airco units within Domoticz.

3 hours on and I’m still trying to get this thing mining again.

take a look here buddy . seems others have issue with your motherboard

PCIe lanes on B450 motherboard confusion : EtherMining (



Will look into it. Thanks.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.