Increase your income with Hive. Invite your friends and earn real cryptocurrency!

High CPU usage process irq/46-nvidia


I have an ETH rig with several NVIDIA cards, 2 1660S, 2 2060S and one 2080S
One of the 2060S gives 44.53 MH but the other just reaches 37. I know it’s the MEM overclock, as I cannot go beyond 1100, when the other goes up to 2200. And I cannot go further because once I increase MEM in that card, one process irq/46-nvida starts taking 100% of CPU, affecting to hashrate of all of the other cards as well. I have to reboot to get back to normal.
Anyone knows why this irq proc. makes such beheaviour?
My current setup:



Hello Alertom,
starting using hiveos since yesterday (my first steps in mining), I have a 3060 ti lhr and the same problem occured for me: each time I apply an OC with freq memory change, CPU goes to 100% in nvidia irq process, increasing the Load Average to the critical 24 limit.
I just figured out it was due to the freq memory change in aonther forum and when I rebooted the rig putting no change on freq memroy, everything fine, mining ETH with a limited hashrate of 35MH while Load Average keeps under 0.2.
NB: I had the issue with both 0.6-208 and 0.6-210 hiveos versions, and with nvidia 460 and 470 drivers…
Let’s see if another guys experiment the same issue. Pending any info, I have to keep the frequency mem untouched.


Hi Albertom,

I was testing around this problem, tuning again the freq core: in fact the problem of irq/nvidia process going TO 100% CPU appears when you setup the mem frequency too high. I was increasing it from 0 with steps of 200: til 1800 OK, hashrate increases while irq/nvidia process remains stable. At 2000 mem freq update, the issue occured again, process stuck at 100% and rig reboot mandatory. After reboot I changed again to the maximum “allowed” freq value (1800 in my case), and everything mining like a charm (tested with lolminer and nbminer, same good result).

Therefore in my case, irq/nvidia process stuck at 100% CPU cas due to a mem frequency tuning too high.

Hope it can helps, let me know if you have still issues with lower frequencies (starting not setting any mem freq tuning).


Similar issue has been observed. When I configured severe OC settings(mostly mem), high cpu usage of irq/nvidia has been observed (by top command) and OS crash.
When I relax OC setting, then I don’t see this issue, so I think it is due to high OC setting and Nvidia driver crash.
I tried on several miners and result was same.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.