More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Help Updating HiveOS

I am using HiveOS [email protected] Current running off a SanDisk 64GB USB with five Nvidia RTX 2070 Supers.
I have kept it up to date with the incremental updates from the browser UI but when I tried to setup a Flightsheet using lolminer or NBMiner I kept getting the error ./nbminer: /lib/x86_64-linux-gnu/libc.so.6: ‘GLIBC_2.25’ not found (required by ./nbminer) or lolminer if using that

After a bit of searching it seems that the dependencies or whatever get borked with incremental updates so I tried to do a full update using “hive-replace -s -y” and I get the error message "E: Package ‘fdisk’ has no installation candidate Failed to install required packages" and it boots me out of the hive-replace wizard.

So my question is does anybody know how to unscrew either lolminer, nbminer, or the hive-replace function?

EDIT: Forgot to mention that I already tried the tier 1 tricks of using “sudo apt-get update”, “sudo apt-get upgrade -y”, and updated the Nvidia GPU drivers to version 510.73.05

You are running on USB. With the driver changes and other things you have executed, you are better off downloading the latest stable release and reflashing with Etcher:

Then, lock down the security settings, run disk-expand, update to lates HiveOS, and proceed. 2070 Supers run just fine on the drivers in latest stable kernel release.

I was hoping I wouldn’t have to physically reflash the USB since its at a remote location.

The GPUs work fine with Gminer version 2.99 but if I try to use lolminer or NBminer I get the whole “GLIBC 2.25 not found” error

You can refresh remote from inside the shell interface.

I use the full syntax for such vs. the abbreviations via hiveshell.
hive-replace --stable -y

Just fired it off on my USB based test rig to confirm it has not changed.

If that fails, you’ll likely need a hands on action.

Yeah that fails, I get the "E: Package ‘fdisk’ has no installation candidate Failed to install required packages" error message when I try to do that

Corrupted files or hacked in my experience.

I’d lean the former in this case since it is USB, had driver changes, and a number of other actions, which are common problems due to slow write speeds.

well, thanks for the help anyway I appreciate it

Try running
sudo hive-replace -y --stable

It the miner packages, most likely, but again, USB is not fun:

hpkg remove miners noinstall
then run
apt update && selfupgrade -f && sreboot

nope, still gettting the GLIBC2.25 not found error.

The fix I’ve found thats worked for others was doing the “hive-replace” command but that fails for me so probably just going to have to physically reimage the USB