Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Help out a new miner

Hey all. I have finally given in and I’m going to ask for help! I have researched a ton and watched countless YT tutorials but I can’t figure this out. Where to start…

Ok, kit. I have purchased a Asus Tuf Gaming H470 Pro (Wifi) motherboard, Pentium Gold G6400 CPU, Crucial 8gb Ram DDR4 2400mhz, SSD 120gb, Corsair RM750 PSU, and finally a Gigabyte RTX 3070 Aorus Master GPU.

Everything was going fine with hardware installation and Hiveos installation. Then the big switch on and Hiveos is not recognising the GPU. It is saying:

Device 9ba8

I have updated the motherboard Bios to 2210 and enabled the Resizable Bar (RTX30 series support). I have also updated the HIve OS (0.6-200@210301) and the Nvidia drivers (460.56)

No change! I then tried the GPU in the second PCI-e x16 slot and it shows up. But the name is not quite what I was expecting:


I briefly attempted to mine using PhoenixMiner and Hiveon but a load of errors came up.

Sorry for the long winded post. Can any of you good people guide this noob?

Cheers, Gaz.

Howdy! Welcome to HiveOS.

Generally, if a card isn’t being detected it is due to hardware related issues.

I recommend checking your:

  • Risers, for faults (if applicable)
  • Cables are seated properly
  • The GPU itself is fully seated into the riser (or directly into the motherboard if you are not using risers)

Make sure that you have the latest stable version of HiveOS. Currently, it is 5.4.80 Kernel version. You can check by looking at your web panel, and looking for the little icon of a penguin.

Hey itsZeroday

Thanks for your information. I will definitely adjust with the hardware and see if I can change things. I am using a riser, so will include that in the checks. Is it worth trying the GPU in the Main PCI-e x16 slot (directly) to see if that makes a difference?

I checked the Kernel version and it is the same but I notice that there is a new update available too.

Cheers, Gaz

Hey itsZeroday

Success!! :slight_smile: Reseating the riser, again, worked. We are now up and running on Phoenix Miner and Hiveon Pool!

Thanks for your help.


Congratulations! I’m glad I could help you get it working.

This is more just a personal message from me, in my time I’ve spent mining and volunteering at the HiveOS discord.

PhoenixMiner is known to inflate reported hashrates, while reducing the amount of valid shares you are receiving. Someone swapped from Phoenix to TeamRedMiner & TRex, and their valid shares doubled immediately.

Highly recommend looking into it and testing it for yourself. TRex is a nvidia only miner, and TeamRedMiner is an AMD only miner. Both are super stable and accurately reports hashrate.

OK. Thanks for the heads up. I will give it a try.

Hello i have the same problem, what do you mean by “reseating the riser”, can you help me please.

Hi Racx

To take it out and put it back in again. Motherboard side and GPU side.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.