Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Have to plug in wifi adapter after every reboot


I’m quite happy that my new WiFi adapter TP-Link TL-WN822N worked right out of the box. Unfortunately I have to remove and reinsert the USB wifi adapter after every boot, since otherwise it won’t connect. I’ve read the WiFI setup thread here on the forums and also tried adding the following lines to /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid MY_NETWORK
wpa-psk hashed-value-of-passphrase

However after adding the above rows, I have to wait for 5 minutes on every boot, since I get:
Network is offline, check your Internet connection
Failed to start Wait for Network to be Configured.
Started Update resolvconf for networkd DNS.
A start job is running for Raise network interfaces (51s/5min 1s).

Any ideas on how to get HiveOS to recognize the USB dongle automatically? I’m running HiveOS 0.6-05. Mobo is Asus Prime B250-Pro.

Hi, did you solve the problem somehow? I have the same USB wifi adapter and it still gets stuck after every reboot… thanks.

I’m also having the same issue.

Hey guys, not sure if it’s the same problem, but this is how I fixed mine, where on boot it didn’t connect to the WiFi anymore:

Added this to /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
  wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

and added some more config to /etc/wpa_supplicant/wpa_supplicant.conf, this is how it looks now:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

For others having issues with the usb adapter, it might also be a faulty linux module which is also related to Ubuntu, since HiveOS is based on it, so you might have luck googling for the adapter name and ubuntu. In some cases the linux module simply needs some tweaking or needs replacing. Hope this helps, cheers!


This worked, for anyone trying to do the same thing, thanks for the help

Thank you very much ! worked for me as well :slight_smile:

Try enable “Power cycle” option in worker > settings. This make hiveos shutdown and power on all the system again, and now usb ports are loaded completly. withou this option enabled, maybe hiveos enable ports in a ghost mode, that cause wifi problem.