Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Hash rate drops 90% after upgrade to version 0.6-224@231003

I was on version 0.6-221@230920, and after upgrading hiveOS to the most current version, 0.6-224@231003 , my hashrate dropped about 90% (all other settings, including overclocking are kept the same, from 128 Sol to 14 Sol per RTX3090

Any ideas on what the issue may be? I always shutdown / power down and reboot after each upgrade or downgrade.

Anyone have any ideas on how to troubleshoot this?


version 0.6-221@230920 screenshot from last week (running a normal hash rate)


version 0.6-224@231003 (hash rate drops about 90%)

AFTER DOWNGRADING FROM 0.6-224 to 0.6-222:

version 0.6-222@231003 (running a normal hash rate again)

You’re on a >2 year old image with outdated kernel and drivers, as a first step id flash the latest stable image, which will likely fix any issues youre having, then troubleshoot from there.

Ok, thank you for the quick response! I had absolutely no idea I needed to go into the shell to update the kernel and drivers since I originally built the mining rig a couple of years ago. I thought the upgrade in the GUI took care of that. :man_shrugging:

Anyway,… I used a Hive Shell to run “hive-replace” to upgrade the kernel from the 5.10.0-hiveos #60 to 5.15.0-hiveos #110 which also upgraded the NVIDIA drivers from 470.63.01 to 525.116.04.

But, then when I tried to upgrade from 0.6-222@231003 to 0.6-224@231003, and shutdown / powered down and rebooted, and had the same exact issue with the extreme drop in hash rate,

I downgraded back to 0.6-222@231003, and shutdown / powered down and rebooted, and now the hash rate is back to normal.

At least I am now on the latest stable kernel and drivers now, but any idea what to try next?

new screenshot:

Try using locked core clocks instead off offset + pl

How do I enable “Lock Core Clock” instead of “Core Clock Offset”?

In the core clock field type the locked core clock you want to set, values above 500 are automatically treated as lccked values.

Thanks! It looks like that worked and I was then able to upgrade to 0.6-224@231003