More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

H61 X79 BTC bios configuration for 5 gpu

Hi everyone

I am building a rig with 5 3060m on a h61 x79 btc motherboard, I can boot on 4 gpu but not on 5 (no bios logo).
All graphics cards and all pcie ports work, I tested.

  • 4G Decode is enabled
  • intel virtualization is disabled
  • audio Azalia is disabled

For the moment I have configured the Pcie bifurcation control like this but I’m not sure if it’s correct:

iou1 pcie port 4x4
port 1A link speed Gen2
port 1B link speed Gen2
iou2 pcie port 8x4x4
port 2A link speed Gen2
port 2B link speed Gen2
port 2C link speed Gen2
ior3 pcie port 8x4x4
port 3A link speed Gen2
port 3B link speed Gen2
port 3C link speed Gen2

If I disable “load CSM” I am forced to reset the bios by removing the bios battery because I cannot boot anymore.

If you have any ideas or tips, please, I’m interested.

There is a video of the bios here:

https://www.youtube.com/watch?v=G4t49Rc8xfk

I forgot some information

Psu Corsair HX850w
processor E5 2630 V2
4G Ram DDR3 1333mhz

I’m using the same board with 3 rigs, never touched any bios settings with any and all work with 5 gpus. Do you have all power connected?

I have 3 “power in” connected on motherboard and all gpu

Does you board only have 6 pcie ports populated? If so connect all of them

yes there are 3 in and 3 out, I can’t test now because I need a spliter (in a few days I will be able to). But normally you just have to connect the 3 “power in” ports like this: https://youtu.be/wqO2nhJIY9k?t=1017

I know, but if yours isn’t working with only 3 try plugging them all in. I run all mine with all connected and haven’t had any problems. My 5x3060 rig has been running for 14 months now on that board

Hi,Thanks for your help keaton.

I tried with 2 psu’s all 6 power pcie’s connected to the motherboard and still the same problem.
but i tested with an old gpu instead of a 3060m and it works.

I did this test again with only 3 power pcie’s connected to the motherboard and it works too.

So 4 3060m + 1 hd 6970 works but 5 3060m doesn’t work

I tested all the 3060m one by one and all works.

I think the problem comes from the bios misconfigured but I have no idea, maybe pcie bifurcation control misconfigured or the “load CSM” that I can’t disable.

what GPU do you have on this motherboard?

Don’t mix psus going to the board, you don’t want one backfeesing the other.

I have 5 2070 supers, 5 5600xt and 5 3060s on my 3 boards

Ok thanks for the advice,

And you never touched the bios?
By default 4g decoding is not enabled so maybe your bios have been preconfigured.

I haven’t ever had to change anything on the bios. Unfortunately I won’t have time until next weekend to check the bios settings on those rigs

Ok that’s nice of you,
Maybe if I move the cards to riser it could help solve the problem because riser are powered separately. I’ll try in a few days when I get them.

Finally I solved the problem, it was to change an option in the bios.

Chipset / North Bridge / IOH configuration / MMIOH size → 128g

So if we start from the default profile, we need for 5 gpu or more :

  • Above 4g decoding → Enabled
  • MMIOH Size → 128g
  • And maybe : PCI Latency timer → 96 PCI bus clocks
1 Like

awesome, glad you were able to get it sorted