Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GPU's not being detected by TB250-BTC PRO

Hi everyone,

Full disclaimer: I am clearly a newbie so I ask for your patience.

I have been going back and forth with my mining rig for the past 3 weeks. Spending a lot of time on it exercising problem solving at 110 %, but I have reached a limit.

I was trying to set up my fourth RTX 3070 FTW3 (I was able to run 3 of them with an AMD 5700 XT) when my PSU (Rosewill HIVE 1000S), along with MoBo (TB250 - BTC PRO), crashed all together. I used a PCIe 6+2 pin adapter to the CPU, but when I tried to power that up it did not. Since then, the MoBo is not recognizing any of the GPU’s, except the Internal Graphic card (which I have disabled and now I can’t even see what’s going on inside).

I tried:

  • plugging the GPU’s in different slots, even without the riser with no success.
  • starting without a graphic card, I was able to get inside BIOS (before disabling the internal graphic card) and updated HIVE OS from the stable version to the beta one, without any changes.
  • different PSU’s with the same results.
  • plugging different GPU’s with the same results.


  • Power is running through MoBo.
  • USB is being recognized by MoBo and functioning properly.
  • Ethernet is going through it normally.
  • GPU’s get power, lights are up and fans are running. I was able to “play” with the fan’s velocity on BIOS settings (that means they are physically detected, but there is something with the software).
  • Processor’s fan is running without issues.


  • Processor: Intel BX80677G3930 7th Gen Celeron.
  • Ram: Samsung DDR4 8GB 2666MHZ (SODIMM w/ adapter).
  • Motherboard: TB250-BTC PRO.
  • Power Supply: Rosewill HIVE1000S.
  • Graphic cards: NVIDIA RTX 3070 FTW3 x4 / AMD 5700 XT x1.
  • USB: TOSHIBA 1 TB, Hard drive.

I am literally losing my mind. It was fun as a project, but now it feels like a burden. It is so frustrating to see the progress of making a few of the GPU’s work and then everything falls apart for an update or adding another GPU.

Any help will be HIGHLY appreciated.

Thanks in advance for your time and patience !!!


Did you try testing the GPUs individually on another motherboard to see if they were being detected? Also 4x RTX 3070s with 1x AMD 5700 XT is too much power draw for you 1000W PSU. I haven’t worked with these cards personally but a quick search online (GeForce RTX 3070 Founder edition review - Hardware setup | Power consumption) shows the RTX 3070s and 5700 XT pull about 200W each. You’re pulling roughly 1000W alone with your GPUs and then you have to supply power to the motherboard, CPU, fans, etc. I’d recommend using a second PSU if you’d want to run everything at once with one. Just remember you’ll need a motherboard that has 2+ 24 pin connectors on it or you’ll need to get a splitter cable since the PSUs won’t start without receiving an on signal from the motherboard. When using two PSUs, try to isolate them as much as possible so no components are receiving power from both PSU i.e. GPU/riser pair are tied to one GPU solely and everything on motherboard is powered by only a single PSU.

Thank you for your tips. I have another PSU that is 500 and I have a splitter cable. I am following your advice on keeping the PSU on “each side” powering their own stuff.
I couldn’t try the GPU’s on another MoBo, since I do not have one, but as stated before, I was able to “play” with the fans on the BIOS settings (I don’t know if that is any indication of anything, but that is what I have so far).
Thanks again, I will keep playing with it.

What’s the HiveOS version you have installed (OS version, kernel, and AMD/NVIDIA drivers)?
Going off of your screenshots, it looks like the OS version is 0.6-198, kernal is 5.60-beta, OpenCL is 19.30, and I couldn’t find the Nvidia drivers. The OS version is the latest but, the kernal and AMD driver aren’t. I don’t know if the beta version has any real benefit over the regular version as you get more up-to-date drivers at least for AMD since OpenCL is at 20.40 on the latest build.

Have you tried using one card at a time and have you tried just connecting directly to the motherboard without the risers? Just want to eliminate the possibility of bad risers or whatever.

Also if trying the cards extensively doesn’t have anything come to fruition, it’s possible that they were damaged when you overloaded your PSU. Hopefully that’s not the case and I don’t have any personal experience with overloading a PSU before. I’m only going off of what I’ve read in online forums.


Hey! Did you resolved this issue? I have the exact same mobo and ran into this problem. I was able to test my gpus on another mobo and they worked fine. The mobo cannot detect any of my gpu’s, no matter the pcie slot or the risers/daughterboards I use.

My only option left is to reflash the bios. Wanted to see if you resolved it another way first! let me know if you did!

I have same mobo with 3060ti and got this problem too. Any solution?

I have the same mobo with 3070 and got this problem too. I cannot find any solution.

Make sure your powersupply can support the GPU’s in stock settings without overclock.

This mobo is very touchy about the power.

Im currently running mine without the molex (x2) cables installed on the motherboard and it has not been an issue at all.

Also try to set the PCI settings in the bios to GEN1

any update? How did you fix your issue?

I have the same exact issue and no idea how to fix it! Please help!

Did you resolve and if so how? I’m also facing similar issue. GPUs are no longer detected in the GUI hiveOS…

I am having the same issue, only thing is, it used to work on all 5 RX6600XT card and then after few days it stopped working. I tried reinstalling OS, different power, different ram, cleared CMOS, but not working. The cards themselves work fine in a different computer. And it’s very frustrating… any help would be thankful

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.