Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GPU power

I have just started mining with HiveOS and still configuring my setup at the moment. Please see attached pic. Does anyone know why is the reported power for GPU#0 is way off? TIA!

unreal numbers usually say that something wrong with bios/hardware setup and causing to variable hashrate on rig

Just switched over from Windows 10. I tried connecting my monitor to the onboard graphics port and later to the 16x PCIe GPU but GPU#0 is still reporting wrong power. Btw, hashrates are absolutely unstable too. In Windows 10, I get a consistently good total hashrate of 366 to 367mh/s for my 12 GPUs before the latest Windows update crashed my rig, that’s why I switched. Do you have any idea what could be the problem? TIA!

Setting PCI-E to gen2 fixed my problem with low hashrate and unreal power draw.

Thanks, brnfex. Just tried but it didn’t help and GPU#0 hashrate is the worst of my 12 GPUs. It fluctuates between 7 to 11 mh/s! The rest are getting better; 29 to 30 mh/s each but occasionally a couple will drop to around 10ish mh/s.

To be fair - I did a few things along with setting pcie to gen2. Wiggled the risers and the small PCIE card, set VT-d to disabled, disable HD audio, set PCIE to gen2. Any of these fixed my issue, but it should be the gen2 setting.
You should also use my undervolt script, by the way. Hive doesn’t set the voltages properly.

LOL! It has been very frustrating for me. I’m not sure if my Asus B250 Mining Expert motherboard has anything to do with it. I just managed to correct GPU#0 power by using another slot but now every single GPU is mining at an incredibly slow 3 to 6 mh/s! LOL!

I just switched the GPU back to the x16 PCIe slot and now it’s back to showing 13982602W!!! But hashrate is back to 29-30mh/s except for GPU#0 mining at around 25mh/s. :s

Tried changing the riser?

Hi all,

Thanks for all your help. :slight_smile:

After several days of trying, I have finally fixed all the issues I have been facing. Now, hashrates are stable and no more weird power usage on GPU#0.

Thought I should share this. For the benefit of all Asus B250 Mining Expert motherboard users, not only must you switch PCIe to gen2 which I did, you have to switch x16 slot PCIe to gen2 as well. <-- I was totally not aware of this earlier because they are on two different pages in the BIOS setup! See below,

Advanced>PCH Configuration>PCI Express Configuration>PCIe Speed>Gen2

Advanced>System Agent (SA) Configuration>PEG Port Configuration>PCIEX16_1 Link Speed>Gen2

Hope this helps some Asus B250 Mining Expert motherboard users. :slight_smile:

I’m dealing with the same sort of issues: High LA, low HR…
Haven’t solved it yet but in case anyone reads this old thread, there is a third BIOS PCI speed setting that should match the other two:
Advanced>System Agent (SA) Configuration>DMI/OPI Configuration>DMI Max Link Speed>Gen2

Finally got this POS Asus B250 Mining Expert motherboard to work with my GPU’s (11 RX570 and RX580). Was getting all or most of them to work but with low HR and High LA.

It took a combination of all the BIOS changes above and here:

Plus the slots used must be like the image from @zcl2 here:

only have 10 GPUS so didn’t use slots C15 and C16. adding the 11th today to slot C15 once I have a missing PCIe power cable. I’ll update this if anything changes.

I Got 11 AMD GPU’s to work using same slots as above plus C15. Ran 4 days.
Then I got greedy and added a 12th AMD (Rx580) to slot C16.
Seems like it took 5 minutes longer to stabilize HR but so far so good.


I have a few more RX580 on order.
Does anyone know if slots matter above 12 cards?

07/01/2019 Update:
It seems which slots are used still matters with this flaky POS Asus B250 Mainboard.
I got 12 GPUs to work using zcl2’s photo / slot layout.
But now in test pilot land. I added a 13th today (still 5 RX570’s, adding 580’s). Tried to use slot A06 but rig booted SLOOOWW (10 -15 min), and then had 50% HR with high LA. Lots of “miner restart” and “OC failed” messages. Just like when I tried to use slots in order A-B-C

Changed card 13 to slot B12 and it ran better, but with a few cards looking wonky (higher Watts and all with lower HR).
I had to bump OC settings a little - moved DPM from 2 to 3 nets same HR per GPU as before this addition.
Now it runs stable and clean: 357.5 MH on 1.182 kW.

OC settings: CORE MEM
RX 570’s Elpida - 925 1730
RX580’s Micron 1050 2200

Update 07/03/19:
Added another RX580 (now 9 RX580 + 5 RX570= 14 GPUs)
intially tried slot C18 but had same HR and LA issues. Moved riser to B08 and 14 GPU are running smooth-ish except HR is low (24-25 mh, should be 29+ at these oc settings) on a couple of the 580’s.

Minor update:
lower HR on two RX580 was due to samsung and Hynix memory requiring diff momory speed. (rest are Micron). 14 GPU seem like near limit before instability. I have another running 12 GTX1070 on Asrock H110 Pro BTC+ that was a similar but different pain in the a$$.
Over 8 or 10 GPU gets tricky.