Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GPU Not Being Detected

I have a weird case that I’m not entirely sure what might be the problem. Do you have any idea or some steps that can be done to diagnose what might be the problem?

Current Setup:
-msi z390 a pro
-8gb ram

  • Corsair CX Series 550 Watt 80 Plus Bronze
    -1200 server power supply
    -Intel celeron G4930
    -2 GPU (3080 FE and 3080 EVGA)

Problem: Either one or NONE of my GPU is being detected on HiveOS; but my rig is running with no problem and it shows that my rig is Online. Flight sheet and OC is already created

Example: I tried connecting my Fe 3080 to the 3rd PCIe slot and my Evga 3080 to the 2nd PCIe slot, and one of my GPU was detected. But after awhile and swapping different PCIe slot with different cards; most of the time no GPU was being detected. Then I decided to go back to one of my successful setup before that at least detected one GPU; guess what? it didnt detect no GPU with the same setup as before?

Tested Already:
1.Risers were also swapped to exclude that as a problem.
2. I tried to connect GPU to each PCIe slots one by one and it did not show up in hive. If both are connected, the Hive shows either none or just one of them (sometimes it is EVGA one, sometimes it is FE)
3. I tried default bios and “normal” setup with 4g, CSM, PCIe2 etc but nothing rly changed/helped.


Go to bios , PCIe speed to Gens2. Also new drivers

I did that already

Update your MOBA’s bios
Reset to factory mode

setup bios as follow

  • Fast boot = Disable

Advanced Mode (F7) → Settings → Advanced Settings → PCI-E Subsystem Settings →

  • 4G DECODE = enable
  • PEG1 = GEN2
  • PEG2 = GEN2
  • PCI Latency = 96 Cycles
1 Like

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.