Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GPU driver error, no temps (Auto fan disabled)

Hi bord, ive been googling my butt off trying to find a solution but cant so here i am.

i have a 6x 1060 6gb rig ive recently migrated over from windows to HiveOS but i cant get the same hashrates as in windows. Please see the following screen shots for my afterburner OC and also the settings i have in HiveOS.
i also have auto fan disabled because it was causing issues earlier on, maybe i should turn it back on?

It mines fine for a while then suddenly the hash drops to less than half around 17.xx Mh/s the GPUs will start showing missing in the webUI then i get the error
“GPU driver error, no temps”

then eventually claymore will say “temperature control thread hangs, need to restart miner!”

after reboot everything is fine GPUs show back up hash rates are fine until it drops again and the cycle starts again.

(as im new im only allowed 1 img per post adding two more post after this)

my HiveOS OC

my HiveOS screen

connected back up my windows SSD and everything is running fine.

this sucks cause i really like HiveOS’s features


I have the same problem, did you solve it ??
Because, unfortunately, I haven’t and I would like to ask for help.

I have the same issue did you solved it ?
I am using 1070 TI

same issue with amd vega 56

1 Like

getting the same error startign today miner stops because of it :frowning:


getting the same issue with 1080ti. It was running about 90 mins and last night it ran for 9 hours without a reboot. I was thinking because i was using too much PL in my overclock but ive been told that is not the issue. I dont mind doing a scheduled reboot every so often to overcome this but i havent been able to figure that out either. Yes I am new, but clearly this issue is persistent in the community. I may try turning back on the auto fans, is that the solution?

1 Like

Im getting the same issue as well on all 3 of my 6 rx 580 8gb rigs. I have been hashing consistently with 10 cards between two rigs and Ive discovered I need to do a bios update and change some settings in the motherboard bios to get the other two hashing so possibly look into your board for the problem? What kills me is my newest rig with a different motherboard is still getting the same error however its not a mining motherboard so I was expecting possible problems. my question for everyone is are you guys running sata for the risers? Im wondering if this could be causing errors because the risers might not be getting enough power.

1 Like

same here

1 Like

Same problem here, how to solve?


I fixed this error (GPU driver erro, no temps) by performing the following on my Nvidia rig:

  • enabling maintenance mode (don’t load drivers) in the Settings tab.
  • rebooting
  • running ‘nvidia-driver-update --list’ command and selecting a previous stable driver version. Let it install. I’m guessing AMD cards have the same ability.
  • clearing all OC settings in the Overclocking tab
  • reboot, confirm mining success with no OC settings.
  • once confirmed, setup OC again as you would a new rig with measured changes.

thanks i’ll give this a go…

To what driver version did you go? Because I am new and I don’t know what version is “stable”.


Hi, Im having the same issue. Sometimes I get this error after one hour of mining, sometimes after 8 hours, not sure if its related to overheating or something (3080 OC Gaming)?

I don’t know if anyone is still having this issue or not, but I was having it to. I’m using 4 r9 390, and I was getting that error randomly causing me to have to restart my miner. I solved it by moving my core state down by one on my OC template. It caused me to go down from 112.5 MH/s to 108.4 MH/s, but its way or stable now.

Thank you so much! This is the answer I was looking for. You are awesome

Unfortunately, it only ran stable for like a week. Now it’s back to giving me the same error. Sorry. I was really hoping I solved that issue for the both of us.

Just got the same problem until now, reboot almost each hour. Any one have same problem?