Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Gigabyte Z390 D cant connect more than 1 GPU

Hi there,
I just got a new Motherboard with the hopes of using 6 GPU’s.
but i can only get it to mine with 1 GPU.
Ive tried Teamredminer and ethermine.
These are my MB Bios settings.
CSM Support - disabled
VT-d - Disabled
PCIE Support - 8/4/4
ABove 4G Decoding - Enabled
Re-size BAR Support - Disabled
IOAPC 24-119 Entries - Enabled
Max Link Speed - Gen1 (Tried Gen2, Gen3 & Auto)
3D Mark Enhancement - Disabled
Ive tried all sorts, if anyone has a Gigabyte Z390 range successfully mining please share your trick :slight_smile:
(all the GPU’s, risers etc have been separately tested and are working ok.)

What is your memory size? on motherboard?

Chaeck all the above

Z390 motherboard BIOS configuration for mining

Let’s get all the settings we need to take care of in the Z90 BIOS in one shot.

  1. Plug in your USB Wifi Stick or network cable
  2. If it is off, turn the PSU power on
  3. Press the power button on the motherboard (see manual for location – be careful of static electricity)
  4. When the screen appears that reads “Press DEL or F2” to enter BIOS, do so. Keep depressing either F2 or DEL until the BIOS appears. Until you’ve entered the BIOS the mining rig may instead present a different screen with system information.
  5. Press F1 to enter BIOS Setup when the option is presented on the screen. You’re now in the BIOS.
  6. Press F7 to enter Advanced Mode.
  7. Update the following settings:
  8. Advanced > System Agent (SA) Configuration > DMI/OPI Configuration > DMI Max Link Speed: Gen1
  9. Advanced > System Agent (SA) Configuration > PEG Port Configuration > All PCIEX16_x to : Gen1
  10. Advanced > PCH Storage Configuration > All SATA devices that do NOT have an SSD set to: Disabled
  11. Advanced > PCH Configuration > PCI Express Configuration > PCIe Speed set to: Gen1
  12. Advanced > Onboard Devices Configuration > HD Audio Controller: Disabled
  13. Advanced > APM Configuration > Restore AC Power Loss: Power On (optional. this is for hard crashes or power interruption reboots once mining)
  14. Boot > Fast Boot: Disabled
  15. Boot > Above 4G Decoding: Enabled
1 Like

Hi nanial,
Thanks for the response.
I have 8gb of memory over 2 4g cards.
I’ve been through all of the settings in the BIOS, save it looks like I don’t have a lot of the settings available to me on the gigabyte bios, things like system agent config are not there…
Maybe gigabyte have a different layout?

I’ve also tried everything in the video with no luck

I have had a response from gigabyte, this board does not support mining.
A new one has been ordered, and this heap of junk will be back on its way to Amazon. :joy:

I know another guy who had the same issue. Once he set “IOAPC 24-119 Entries - Disabled” all the other gpus were found.

Mine works with 3 gpu, but no more. IOAPC 24-119 Entries - Disabled is necesary

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.