Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Gigabyte RX 5700 XT OC REV 2.0 samsung memory bios mod issues

So I am having the hardest time getting my gigabyte 5700 xt OC with samsung memory to bios mod. I did all the normal steps using red bios edit but for the life of me cant get it hashing. I also cant seem to find any info on these cards with samsung memory. Does anyone have a working unsigned BIOS for this card? Any help would be appreciated.

1 Like

I tried a lot of methods on all sorts of cards with Samsung memory. They suck! I ended up going back to stock on all my Samsung 5600 and 5700 cards. My Micron cards work great 58Mhash on 5700

Ah this makes sense then why I’ve been having nothing but issues trying to mod my samsung 5600! I guess il just leave it stock.

Yes, leave it stock for now. I haven’t figured it out for samsung memories. I heard other people have BIOS that works, I just don’t have it. So I’m leaving all my samsung cards stock BIOS and low memory clock setting. They say don’t exceed 910Mhz, but some cards only run at stock 875Mhz.

1 Like

Hey I actually ended up rolling the dice today and flashed a modded bios for a Powercolor Radeon 5600 XT on mine and it works really well. I guess apparently even though my GPU says “Samsung” in Hive, it has a combination of Samsung and Micron memory chips.

I verified the part #s for the memory using RBE to check the stock bios against the modded bios, and they matched. I’m not able to undervolt down to 680mV, and get 41.5 mh/s when memory is 900.

Before I used to struggle to get 39 and usually would become unstable. I’m able to get 42 mh/s if I boost memory to 910 but i’m not quiet sure it’s stable so im sticking with 900 for now.

Hey everyone, sorry for the late replies. I was able to get help from Crypto Peasant over at red panda mining on discord. Here are the timings I am using for my Gigabyte RX 5700 XT.

I use the below for 1550, 1800, 2000, 2250. Been running this timing on all of my samsung 5700 xt’s, not just the gigabyte.


1 Like

hi bro i used your code but didn’t work and my vga gone break! i need more help :frowning:
thank you

Just reflash the original BIOS and youre good

Howdy all, i’ve bricked this card and am looking for an original ROM file, we backed ours up with gpu z and flashing it back to its original bios does not fix the card. Any help on this would be greatly appreciated

Hello, Did you get any luck with overclocking this GPU? I have tried different settings but it is freezing my operating system after a while.

What hashrate do you get with this? Could you share your specific settings?

This is using TRM. Sorry its been a minute since I looked at this thread. Let me find a way to upload the bios im using.

I have been using this stable since I made this thread. Hope it helps.

Thank you man. I will try this one by weekend and let you know

I have tried your settings with my rx 5700 xt. But it failed. After I restart my computer, in device manager, my rx5700xt shows up. But when I try with miner it gives 0MH/s. When I try to open AMD radeon software, it says there is no compatible graphic card is installed in Win 10. I think my graphic card just does not like OC. Maybe unlucky SoC??? Did you experience this? Or am I supposed to switch to HiveOS?

this bios mod working for me with 54.5MH/s @105W: M-Samsung-F40-Gigabyte-Gaming-RX57XT-v68-mod-son.rom

how’d you go?

Can you upload one more time the bios from you gigabyte card (micron mem)

omg…you´re on TRM miner…lower your core clock and check your power and hashrate. I bet you can go down to 1300 with no significant loss in mhash.

TRM needs less core clock than other miners…this results in lower core voltage setting and power usage.

this is mine

for 55 mhash I need to go to around 1260 clock / 750 core voltage and 890 / 900 mem. but then my power usage goes up too high…

hello bro…currently i have problem for my gigabyte rx 5700 xt oc rev 2.0…can i get stock bios for this card
my email:- [email protected] …tq for help