Increase your income with Hive. Invite your friends and earn real cryptocurrency!

GA 104 on 6xRTX 3070

Hi guys,

I am having trouble with my mining rig. The GA 104 sign for a Gpu constantly pops up on Hive. The cards are two mounts old ( 6 x RTX 3070 gaming ), and I have no idea what went wrong.If I put only one card into the rig the problem still occurs.

I changed the motherboard for a brand new one :white_check_mark:
Bios setup✅
New risers :white_check_mark:
New wiring :white_check_mark:
The only things that I haven’t changed are the PSU,CPU and the GPU
Overclock Mem 1100 Core 2100

Can you recommend to me what else can I do??
I tested every card. I put them into another rig ( exactly the same setup ), and it run well. :man_shrugging:

What version of HiveOS are you on? What linux kernel version do you have?

I’ve put some stuff here in this thread that might help if you have not tried it

I have attached a GPU to the motherboard, and it runs well at the moment with one GPU. I updated hive to the latest version to the 703, and the driver is 465.31. After these updates, I tried with a new riser, and the problem occurred again. I checked my bios settings, but I could not find anything wrong.

Max link speed= Auto
Above 4G memory= Enabled

The rig was running well for two months, but now somehow, he doesn’t like the risers.

Is there anything that I can set in Hive, also where can I find the Linux kernel version?


You are going to want to set your link speeds to GEN2. If it does auto it will listen to the card for the speed. GEN3 is spotty at best and GEN4 straight doesn’t work. Start there and see how that goes, it might just work since the riser itself probably doesn’t support GEN3 or 4.

In the screen shot here you can see the kernel in the very bottom right

1 Like

Hellooo JustAGuy,

A magic happened tonight!!! My rig started to work again. Thanks for your help. GEN2 set up worked👍

I really appreciate your help.

1 Like