Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Fan Control/OC on R9 series cards?

Hi all-
HiceOS recognizes my R9 290x GPUs, but does nothing with the fans, even when set to 100%, claymore reports 44% and temps skyrocketing.

How can I (even from command line) kick the fans to 90-100%?

Well, it looks like I may be able to add “-tt -50” to the command line parameters. I’ll try it later.

what version do you have i have r9 380x and h7950 and they are not working on this distribution

Blah. I want to comment on initial thread.

I believe I have the same issue. I managed to get below pasted lines from hive agent when settings are saved and miner is starting. I have no problem setting up RX series but R9s I get following text:


Wed Feb 14 19:30:52 CET 2018                                                                                                                            
ls: cannot access '/sys/class/drm/card*/device/pp_table': No such file or directory                                                                     
No AMD GPUs found as /sys/class/drm/card*/device/pp_table
With payload                                                                                                                                            
> Sending "danger": Exec failed, exitcode=1

If we are accurate I believe OC and fans don’t work at all. Hashrate is what I am used of but thermal management is killing me. Anyone has idea what we should put in the file miner is looking and we can cool our cards.

You can but it doesn’t work. Your card runs at 50% anyway she is above 75°
I doubt is possible to set fans with amdcovs either. :disappointed:

I made a sloppy workaround. I decided to control the fans manually and decided to activate them and give them fixed value in %.

Activating fan 1 by 1!

sudo echo "1" > /sys/class/drm/card[b]0[/b]/device/hwmon/hwmon[b]1[/b]/pwm1_enable
sudo echo "1" > /sys/class/drm/card[b]1[/b]/device/hwmon/hwmon[b]2[/b]/pwm1_enable
sudo echo "1" > /sys/class/drm/card[b]2[/b]/device/hwmon/hwmon[b]3[/b]/pwm1_enable

Manual control works but you don’t need it at all!

sudo echo "75" > /sys/class/drm/card[b]0[/b]/device/hwmon/hwmon[b]1[/b]/pwm1
sudo echo "55" > /sys/class/drm/card[b]1[/b]/device/hwmon/hwmon[b]2[/b]/pwm1
sudo echo "60" > /sys/class/drm/card[b]2[/b]/device/hwmon/hwmon[b]3[/b]/pwm1

Hive & Claymore settings:
-you can adjust cclock and mclock in OC Hive panel. Leave fan bracket empty!
-add to Claymore config override -tt 70 or something that suits you and make lower fan threshold with -fanmin 65,50,70,55.

After activating fans with pwm1_enable I have my R9 Rig cool again. After reboot I needed again to activate fans and they took within 1 minute the settings from Claymore. I hope above helps you too. :slight_smile:

I killed code above when I tried to bold the changes in lines. Again. :expressionless:

sudo echo “1” > /sys/class/drm/card0/device/hwmon/hwmon1/pwm1_enable
sudo echo “1” > /sys/class/drm/card1/device/hwmon/hwmon2/pwm1_enable
sudo echo “1” > /sys/class/drm/card2/device/hwmon/hwmon3/pwm1_enable

with r9 290x works with
sudo echo 1 > /sys/class/drm/card0/device/hwmon/hwmon2/pwm1_enable
sudo echo 200 > /sys/class/drm/card0/device/hwmon/hwmon2/pwm1
verify : with cat everytime, good way, level :wink:

I am new on this forum, But i found this forum very use full. i fix my problem for my R9 280x.
And i add a small script to the boot, i am not sure if its the right way, but its work.

1- I log on with ssh terminal on my hive os. make sure i am root.

2- created a file with nano /usr/local/bin/fanspeed
I have to use diferent command because my device was on diferent slot.
into the file i put the command
echo 1 > /sys/class/drm/card1/device/hwmon/hwmon3/pwm1_enable
echo 145 > /sys/class/drm/card1/device/hwmon/hwmon3/pwm1

Save file, Ctrl-X, Enter.
Make it executable, chmod +x /usr/local/bin/fanspeed

3- Test executable with hive os Launch command button,
click on launch button at the top bar menu, put “fanspeed” and execute

4-For make it bootable,
With the terminal edit nano /hive/bin/hive
At the end of file before exit 0 and right after echo2 Hive start Finished
add the new command just created fanspeed
Reboot sys

For my self i created diferent scipt with fan speed, so i can execute one with fan speed at 50 %, one at 60% and 70% etc, depend on the money i mined. Just created a diferent file call it fanspeed50, and change the value on the second line. ex : echo 145 > . … change it to echo 135 > . .

I hope it can help