Increase your income with Hive. Invite your friends and earn real cryptocurrency!

EVGA GeForce RTX 3070 XC3 Ultra - HiveOS not spinning first of three fans (but all fans spin with Windows 10)

On my EVGA 3070, the first fan does not spin while using HiveOS, despite forcing fans to 60%. All three fans spin at boot, they also all spin if I use this card on a Windows machine, but with HiveOS the first fan does not spin while the other two do.

Any suggestions on how to correct this? I cannot see a setting to control individual fans in HiveOS, however, this is an option when using x-precision in Windows to control individual GPU fans.


Just confirmed, nothing wrong with my GPU fans, all 3 work with Windows, just not with HiveOS.

GPU: EVGA GeForce RTX 3070 XC3 Ultra 8GB

This is a popular GPU, hopefully someone has a suggestion.

I’m having the same issue, can’t switch my farm over to Hive because of this. Did you find a fix?

1 Like

Unfortunately I haven’t found a fix; I begrudgingly had to switch back to Windows because of this.

Same issue here. The 3080 works fine.

I am checking the temps on the 3070 and there are not problems. So… imma run it until I see issues.

A guy from another post gave me this. It is worth a try for you.

BTW everyone, I am currently getting about 10Mh/s more from gminer than T-rex.

apt update
nvidia-driver-update to update the driver to 460.39
then nvidia-driver-update --nvs to reinstall the nvidia settings

Also I did an apt upgrade as well on my linux machine to upgrade any package that was upgradable.

Another thing I did on my board is make sure my PCI-e was in GEN2 or else i’d get a X Server Start error and OC settings would not apply until GEN2 was applied.

1 Like

How would one apply this fix, and did it work? I have a 3080 XC3 Ultra and a 3070 XC3 Ultra that I’d love to run on Hive, but currently cannot.

I also have this issue. I tried the fix that Cryptosynapse said might work but it didn’t. I also tried resetting the gpu to factory settings on windows but that also didn’t work. I have three of these and 2 of the three are affected but the third works just fine. Do you think that copying the vbios from working one will make the others work?

OK, I found a workaround. Simply set the fan speed in windows 10 using Precision X1, and confirm all 3 fans are spinning, then boot into HiveOS, all 3 fans should spin.

Have two EVGA RTX 3070 - completely identical, in the same machine, one of them are running with all 3 fans, the other one only with 2. In Windows it works. Tried updating to latest drivers - still not working.

1 Like

in same boat need a fix for this really don’t want to use windows

I’m having the same issue, can’t switch my farm over to Hive because of this. Did you find a fix please !!!

Just moved a 3070 XC3 from Windows to HiveOS and experiencing this issue. The card however is not increasing in temp, and I just placed a big fan near it blowing cold air on it and a couple of other cards. Is it really that big of a deal I’m wondering as long as temps are controlled?

I have 3080 ti XC3 and in windows with MSI I only get two fans spinning. I install Precision X and if I adjust the fans there then they all spin. It also update the firmware on the card. But on afterburner only 2 of 3 pans spin. I moved it to Hive and same issue the same two fans spin and third does not. It’s keep temperature ok but the two fans have to spin at 100%. Anybody get this fixed?

Have you tried my solution above? confirm all fan spinning in Precision X, save settings, then boot into hiveos right after that

Hi, I tried to move my rig to hiveos today, and I had the same issue with 2 3060 TI xc3 cards and one 3080 xc3, all three non LHR.

I had to switch back to windows too.

I don’t understand how a problem like this, raised since February is still not fixed, and no message from the HiveOS team…

Same issue with a 2080ti FTW3 kinda crazy works fine in windows but temps get to 65ish and still only one fan spins … nobody on here found a solution?

OK so here’s what I did to get mine work (everything worked fine in Windows).

I’m going to list all the steps because i don’t know which fixed it, but this is what I did:

1.) Boot into windows open Precision X1 and set all fans to 100%, click the link icon and save.
2.) While all fans are spinning 100% turn computer off completely (hard power off)
3.) Boot card in hive, while running connect external fan to FAN pins on back of card
4.) Flip the OC switch (while running)
5.) Reboot

I know this is a really weird sequence of events, but I was fed up with it not working, and somehow this happened to work. None of the LEDs turn on (which I love) but all 3 fans are spinning now in hive :smiley:

Also make sure you’re using the latest driver as well, from cli in hive type

nvidia-driver-update --list

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.