Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Error: can’t allocate initrd”

Hey guys,
I am having following troubles wth 7th gpu on my Msı B450 Gaming Plus.

First of all, all GPU’s and risers work fine separately.
whenever added 7th gpu on m2 slot l have error “can’t allocate initrd”
I trid bios upgrade which did not work. After that l changed cms/uefi setting, 4G enabled, secured boot enabled/disabled. non of them worked. Even l tried different ssd and installations. Non of them worked :frowning:

Any solution or advice ?
I have 4 of these motherboards on my rigs and two of them run me crazy and ruin my night.

I had the same problem with my msi x470 gaming plus max.
When the 7th is added I got that error…changed everything about pci, m2, csm…and still this error.

And, finally found a solution.
You can fix that changing the boot order at BIOS. You should put first boot device your SSD complete drive, not SSD:PartitionXXX. The same if you are using USB, put USB complete drive, not USB:PartitionXXXX.

This worked for me and now I have 7 GPU enabled and working. Good luck!


Thank you for the answer. I will try it when my rig crash again. For now l m running them seperately

did you get the solution please let me know

It s about bios settings . Take out pci extender on m2 slot.
after entering bios you should choose uefi
then change boot priority as a usb uefi
after that restart your rig. happy mining :clap:

Também tenho uma Msı B450 Gaming Plus, fiz o que você falou aqui e deu certo, obrigado por compartilhar o conhecimento.

you can try what l said above.
I had same problem on my two rigs and they re working now

You’ve saved the day!
Was able to boot 7 gpus on Asus Prime B450-PLUS with pci-e extension!
Thanks a lot!