More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Dual mining zil on TRM

Was trying to set dual mining on teamredminer, but I’m having some issues.

The interface shows the options for dual mining

However the miner config doesn’t show an option for zil, and auto selects eth

I know that zil is a variation of eth. When updating the miner, hive complains about the algo2 selected.

Even tried to enter the option manually (–zil … --zil_end), but didn’t work either and kills the card.

The miner config looked like this

-a ethash -o stratum+tcp://eth.hiveon.com:4444 -u wallet --eth_worker rig -p x -o stratum+tcp://eth.hiveon.com:14444 -u wallet --eth_worker rig -p x -d 0
--kernel_vm_mode=RR
--eth_smooth_power=1
--eth_dag_cache=0
--zil 
-o stratum+tcp://us.eth.k1pool.com:3840 
-u k1wallet.rig
-p x 
--zil_end

However it crashed after it seemed like it was going to work

[2022-08-17 19:05:11] Pool eth.hiveon.com received new job. (job_id: 0x93ec10aa5e2..., diff 1.000 / 4295 MH)
[2022-08-17 19:05:13] Pool eth.hiveon.com received new job. (job_id: 0xb51fcebe1ba..., diff 1.000 / 4295 MH)
[2022-08-17 19:05:13] Pool us.eth.k1pool.com received new job. (job_id: 0xe2d8a5dcc92..., diff 1.164 / 5000 MH)
[2022-08-17 19:05:14] Watchdog script executor thread executing script 'watchdog.sh'
[2022-08-17 19:05:14] ------------------------------------------------------------------------------------------------
[2022-08-17 19:05:14] Mining ethash+ethash with 1 GPU workers
[2022-08-17 19:05:14] GPU PCIe      CUs CoreMHz SocMHz MemMHz TEdge TJct  TMem  FanPct  FanRpm  VDDC   Power  ETH Cfg
[2022-08-17 19:05:14] 0   05:00.0   40  1050    1200   1071   38C   39C   44C   28.63%   957    650 mV  22 W  R480 (*)
[2022-08-17 19:05:14] (*) Gpu is still tuning.
[2022-08-17 19:05:14] 
[2022-08-17 19:05:14] Stats Uptime: 0 days, 00:00:31
[2022-08-17 19:05:14] ----------------------------------------- GPU Status -------------------------------------------
[2022-08-17 19:05:14] GPU  0 [38C, fan 28%]      ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0 hw:0
[2022-08-17 19:05:14] Total                      ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0
[2022-08-17 19:05:14] ----------------------------------------- Pool Status ------------------------------------------
[2022-08-17 19:05:14] eth.hiveon.com             ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0
[2022-08-17 19:05:14] eth.hiveon.com             ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0
[2022-08-17 19:05:14] ----------------------------------------- GPU Status -------------------------------------------
[2022-08-17 19:05:14] GPU  0 [38C, fan 28%]      ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0 hw:0 (PAUSED)
[2022-08-17 19:05:14] Total                      ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0
[2022-08-17 19:05:14] ----------------------------------------- Pool Status ------------------------------------------
[2022-08-17 19:05:14] us.eth.k1pool.com          ethash: 0.000 h/s, avg 0.000 h/s, pool 0.000 h/s a:0 r:0
[2022-08-17 19:05:14] ------------------------------------------------------------------------------------------------
[2022-08-17 19:05:14] GPU 0: detected DEAD (05:00.0), will execute restart script watchdog.sh
[2022-08-17 19:05:15] Pool eth.hiveon.com received new job. (job_id: 0x090dea86ae5..., diff 1.000 / 4295 MH)

The dual coins arent all supported by the miner, since zil isn’t technically mined along side and instead is switched to, the config for dual coin for trm doesn’t work the same way it does for other miners. It Looks like you’re trying to mine eth at hiveon plus eth and zil at k1 pool? That’s confusing trm.

silly trm. Other miners are able to figure it out

Will try Kroxy with trm. Thanks

This is how I got dualmining with TRM on hiveon for eth and ezil pool for zil

Miner extra config arguments:

–zil -o stratum+tcp://eu.ezil.me:5555 -u ethadress.ziladress.worker -p x --zil_end

You have to put your addresses and worker name in.

Had tried that, but my card died. Thought it might had been the –eth_dag_cache=0 option, but even without that it dies. Baaad trm

The way I normally mine zil isn’t using a proxy, so the miner has to switch to the zil and stop mining eth.

New mechanism from v0.8.3

From v0.8.3, take any existing TRM command line configuration for
ethash, kawpow, verthash or autolykos and add:

–zil -o stratum+tcp://eu.ezil.me:5555 -u .. -p x --zil_end

preferably at the end of the command line. The miner will pause the
primary algo and switch to ZIL during the ZIL windows, then switch
back to the primary algo afterwards. More primary algos might be added
if there’s enough interest. The intention is that the miner
automatically configures the primary algo to work well with the dual
ZIL mining. It is fully possible to add more arguments between the
–zil and --zil_end arguments, all arguments in USAGE.txt are
available, but the default configuration chosen by the miner should be
optimal for most setups with the following settings:

  • Cached copy of the ZIL epoch 0 DAG.
  • Adjustment of memory allocated for the primary algo to fit the ZIL DAG.
  • Choose ethash A-mode for the ZIL mining.
  • Use the standard faster kernels for 4GB gpus since the DAG is max 1GB.

Thanks again, but it isn’t working for me.

Kept seeing –zil, so I thought I messed up. Gave it a try but it is -–zil (two dashes)

TRM reports GPU 0: detected DEAD (05:00.0), will execute restart script watchdog.sh

@keaton_hiveon

Seems the problem was a bit more complicated. You need a few extra options for trm to dual mine correctly

Ended up using

--eth_config=B
--eth_dag_alloc_patch
--eth_dag_cache_verify
--kernel_vm_mode=RR
--eth_smooth_power=1
--eth_dag_cache=0
--zil_start 
-o stratum+tcp://us.eth.k1pool.com:3840 
-u k1wallet.rig
-p x 
--zil_end

Thanks guys

Got the definitive solution. The previous one, wasn’t doing better than 25 Mh/s

Was told by GKumaran to use

That was for large ram gpus

for small ram gpu use:

–eth_config=B --eth_dag_cache=0 --pool_strategy=min_epoch --eth_dag_cache_verify -o -u -p -o -u -p

This gave almost as good results as using a proxy (weird)

The core clock had to be increased