Increase your income with Hive. Invite your friends and earn real cryptocurrency!

[drm:amdgpu_get_bios [amdgpu]] *ERROR* ACPI VFCT table present but broken (too short #2)

Hey guys!

My rig worked great for weeks on end, however recently it started failing every 24-48hrs, without any error message displayed on screen or in hive dashboard… however I noticed that on startup I get this error message;
“[drm:amdgpu_get_bios [amdgpu]] ERROR ACPI VFCT table present but broken (too short #2)”

How can I figure out which gpu(s) is having issues?

It’s an all AMD 10gpu rig Running on a Asus b250 mining expert with 4gig ram.

Any help would be appreciated!


Did you ever find a solution to this problem? I am having the same issue.


I also have the same issue when i add 3rd GPU to Mining rig…
Plz update here if u get any solution…

Same issue here. Added a second RX570 and HiveOS is only recognizing the my initial card.

Any solution on this error?

Looking for answers for what this is as well

You need to flush withe the original bios of the card.

I also facing this issue, pls update if someone got any solution


Flash the original BIOS, then after you try to flash back the modded one with no errors on init!

Did you find a solution? Im facing the same problem

Same error all GPU’s with stock bios. The rig ran fine for six months this error started coming up in past 3-4 weeks.

Error: kernel: > GPU driver error, no temps [drm:amdgpu_get_bios [amdgpu]] ERROR ACPI VFCT table present but broken (too short #2)

11x RX 580s total, Asrock H110+ Pro BTC, Intel i3-7100, 16GB RAM DDR4 3200, 1x 1600w Primary PSU 3x HP 750w PSUs all running at 240v and USB Boot SanDisk 3.2Gen1 30.8GB.
8x MSI 8GB Armor OC, 2x Asus 8GB Dual OC, 1x XFX 8GB

[email protected]
A 20.40 (5.9.0325)

Dag Cache

I had this same problem, back then solved it by flashing the Beta image, nowdays the stable version works ok, did you solved your problem?