Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Dpkg error during setup

Hello fellow miners. I’m new. I have just completed building my first rig.
Asus B250 Motherboard w/ Intel e1000e ethernet
c3900 processor
16gb Thumb drive for HiveOs
AMD Radeon 5500 XT Video Card (one so far)

I’m having issues getting everything to play nice with each other.
I’ve updated the OS from downloads.
I’ve updated the driver for the Ethernet card
I’ve updated the driver for the video card (ver 19.50)

My console on my laptop says Hiveos recognizes it, and does indeed read the card, but, it isn’t mining, and now, it no longer recognizes either my WIFI or ethernet.
And is throwing up error messages if I try to “selfupgrade”

Any suggestions?
Thanks in advance

This is the message I’m receiving when I try to boot up.

And, yes, I’ve tried both “hello” just as Lionel Ritchie as I possibly could, and “firstrun -f” and got the same error messages.

USB stick with low write speed
How to solve it I answered on other topic

I upgraded from a USB thumb drive (I had an SSD drive on order, but it said "somewhere between mid OCTOBER and mid effing DECEMBER for it to arrive) so I tried the thumb drive route, and now understand why it isn’t used often.
I’m making due with a formatted 80GB hitachi from an old laptop, and it’s made tremendous differences in transfer speed, but I’m still not mining. I’m 5 DAYS new to Ubuntu, (although I’ve used DOS and BASIC long, long ago) so, I’m still trying to figure out exactly what I’m doing wrong.
Thank you for any sugguestions.Ethminer error

More Miner Information. I only have one card that I’m mining with. It’s not like I’m setting up multiple cards.

Tried another pool.teamredminer

First at all you needed describe your configuration for ability for help will be easier
I see broken system on you screen (no AMD OpenCL driver version)
Are tried update AMD drivers ?

the first thing I did after I booted the system was to go into maintenance mode, and install the newest AMD drivers. I was hoping that would help. I tried the rm code line you suggested, and now it’s saying it can’t find it for selfupgrade, either.


Miners failed to start because broken AMD drivers installation.
You’ll need reinstall drivers or reflash image

I think the driver file is still on my drive. The tar file is in red, and I think the file itself is listed in

Also, having issues unpackaging the new ethernet file (e1000e) that seems to make my LAN actually start up with the computer, instead of searching for it. I’ve tried several times just to get it to unpack. no luck. It says “it’s not a Gzip file” even though I got it directly from Intel.

Formatted the drive (again, yay), reloaded hiveos, first command was “selfupgrade --force 0.6-164”
Rebooted, and started working like a charm. Thank you.

I have a slightly different issue I’m dealing with, and I was hoping it could be cured in the next upgrade, to avoid me really, really screwing things up in my system (again) just to try to install a card that should be mining with no problems.
As you know, the market for new cards has gone insane overnight due to renewed interest in mining. I REFUSE to pay $800+ for an RX 5700 XT I paid $440 just one month prior, or $400+ for an RX 5500 XT EVER.
I’ve been researching older server cards, and have found some with specs suitable for mining. Preferable, actually. I have three AMD Firepro S9150’s that I recently purchased for around $150 each. They spec out very nicely for an older card. Simliar transistor count to a 5500, but with twice as many cores, and twice as much (16gb) GDDR5 RAM. The main problem is, It seems to want certain lines of code that aren’t installed in the standard AMD “openCL” driver, unless you either do a full “pro-install” which causes my setup to black out and reboot midway through due to attempting to setup a different “dkms” file. When it gets to that point, it goes “hard reboot.”
If I try to “uninstall” then reinstall, I says I have to run;
sudo dpkg --configure -a but goes into hard reboot while doing so.

It wants to use a “legacy-open source” version.
While I’m starting to pick up on basic programming and setup with LINUX, this seems to be a couple of Notches above my pay-grade, so to speak.

this is what I supposedly need help with, except it would be 20.40 for Ubuntu 18.04 (same procedure, just for the server version of the driver) ;

Update, 2021.01.20.

To install OpenCL part from AMDGPU-PRO, run:

./amdgpu-install --opencl=legacy --headless --no-dkms

Last tested with:

  • Ubuntu 20.04.1 LTS, Linux 5.4.0-62-generic, AMDGPU-PRO 20.45-1188099-ubuntu-20.04, Radeon RX 480 (Ellesmere).


  • As of AMDGPU-PRO 20.45-1188099-ubuntu-20.04 (and perhaps earlier), amdgpu-install does not honor --no-dkms option when run with --opencl=rocr , i.e. amdgpu-dkms is intalled and kernel module amdgpu.ko is compiled, replacing the one from Linux kernel tree.

  • amdgpu-install may complain that it can’t install, because this is not Ubuntu version expected. Edit /etc/os-release and replace Ubuntu version with what installer wants. After amdgpu-install completes /etc/os-release may be changed back.

  • In Ubuntu 20.04 /dev/kfd is owned by root.render, not by Add user intended to use OpenCL to render group.

‘amdgpu’ is an open source Linux kernel module for AMD graphics. It is available in stock kernels starting with Linux 4.2. OpenCL support can be added by installing libraries from binary AMDGPU-PRO driver download, provided by AMD. AMDGPU-PRO itself only works with certain distributions/releases/kernel versions.

Check lsmod and /var/log/Xorg.log that you have amdgpu loaded and working.

Download AMDGPU-PRO package for your Linux distribution from

``**tar -xvf …** to upack the downloaded file and run:

amdgpu-pro-install --compute ( see Update above )

which is for “compute only”, i.e. it will install only the following:


Apparently, I can’t do this unless I either run;
$ sudo apt install build-essential dkms
or it tries to install it.

Any thoughts? A $5000 (new) server card with minor mods for effective cooling and all for less than $250, that should be able to hash in the 25-30 MH/s range with enough memory to say “DAG file? What DAG file? Pfft. DAG file.” is worth trying to get running, IMO.

Thank you for any help you can provide.