Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Did I just bricked my two Gigabyte Vega 64?

Hi Guys,

I tried to flash my both Gigabyte Vega 64 with the Vega 56 Bios and I think I got the wrong one:

I flashed them both with this BIOS and now they are undetected in HiveOS. Are they now ready for the trash bin or can I rescue them anyhow? :frowning: :frowning:

You can but you will need to check them in windows


fortunately, I installed both cards on my regular windows computer. Both are working, means, I can see the screen and work in windows so far.

Both cards are recognized as Gigabyte Vega 56 Gaming OC cards.

What I tried so far to reflash the cards back to Gigabyte Vega 64 Gaming OC BIOS:

  1. Downloaded this BIOS VGA Bios Collection: Gigabyte RX Vega 64 8 GB | TechPowerUp
  2. Tried to flash bios back with amdvbflash over Windows 10, DOS and via bootable USB stick => everything has failed.
  3. amdvbflash via Windows 10 and DOS says: SSID mismatch
  4. amdflash via rufus and bootable stick says “A newer ROM already programmed”

I’m just wondering, because it seems that both cards working in Windows but I am not able to get them back to their original bios versions - what am I doing wrong here?

This is the error message I am getting when going over command line in Windows 10.

In amdvbflash, I saw that I am able to modify SSID & SVID. Is that the way to go? When yes, how? :slight_smile:

When you are flashing it you need to use the force option to force flash it and ignore errors

Flash it with stock bios. Go in amd website and find the stovk bios. And to be sure remake your bootable hive and also don’t forget to add your rigs in it before running.

Hi, I already tried every single possible combination in amdvbflash with amdvbflash -p -f 0 romname.rom
I also tried with options like -fa -fs. Nothing works, it always says, that the SSID mistmatchs.

Can you give me a link, which bios you mean by “amd website”? Don’t want to completely brick the cards, because now they are running as Vega 56. I just would like to get them back to Gigabyte Vega 64 Gaming OC cards :slight_smile:

Holy shit… there are some updates you will rofl.

Just for the fun, I downloaded the AMD VBFlash / ATI ATIFlash 2.93 (older version) and tried the same with:

amdvbflash -p -f 0 gigabytevega64rom.rom

Seems good or not?

When I enter the official Gigabyte @BIOS tool with the latest bios Version from gigabyte website (RVG64GO.F2), it says:


GPU-Z shows the following:

It looks a bit weird. But did I rescued the card right now or should I do something else?

Ok I think I got this thing solved!

Installed the latest driver for the Vega 64 and see there:

Now, I will put the first card back to the rig and see what happens.
Lessons learned: Don’t touch things without brain you don’t really know 100% about.

If the Vega64 is recognized in my rig, I will don’t touch it - may be let it just hash with its poor 43 Mh/s, but be safe :slight_smile:
Then in the future, I will just replace the both Gigabyte Vega 64 with RX6800 …

i think you can flash 56 bios on it but havent done it and i dont recommend it. they use it to reduce power on it i think. just put it in hive and OC it properly. it should work.

1 Like

This might help someone:

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.