Increase your income with Hive. Invite your friends and earn real cryptocurrency!


I have 2 other rigs running ok on same lan. I had a loss of power, like a flash out that lasted less than a second. Had trouble getting rigs back up so I reinstalled hiveos, but for this rig it won’t connect to server, so I even created a new worker definition (although I used same name, I’ve changed it now) and new setup with new worker still won’t connect to farm. I did also notice when I setup worker than Lan Config was on Static, I tried to change to DHCP but it wouldn’t change. I looked at other rigs and they are all DHCP with no network issues.

Using lolminer, when lolminer tries to connect, I get message, rig.config found but cannot connect, then the error code CURLE_COULDNT_RESOLVE_HOST.

I also tried restarted network devices, Moca adapters, ethernet switch, and router, but did not restart cable modem.


  1. Is it possible my ethernet port component on mobod is fried, it was a brown out but not a surge. I figure my M.2 SSD got corrupted so I reformatted and did new setups, as i said, other rigs have worked fine.
  2. Is it a Wan issue and something I’m missing on setup or dashboard?

first of all check if the linux is showing the lan card. if you have it listed properly there than its not fried. then try configuring the lan to DHCP. your rig should get IP from your router like the other rigs did. I cant believe a power surge cause so much trouble like preinstalling and stuff…

Thanks for your response, i ran ifconfig, I get a system response but not an ip assignment, it seems this command would first return the

eth0: ip address assigned with netmask and packet stats, then display the lo: ,
I only get second part of response, lo: netmask, so it seems there is no communication with router, I know router and eth switchc are ok as I have other rigs running through them.

The thing that concerns me most is that there is no green light on ether switch, I changed ports and cables.

yellow ? check you cable maybe faulty connector. if you have a PC with windows, connect the cable and see if it works. switch to DHCP first and then check the ethernet adapters.
use this
sudo lshw -class network -short

it should display something like this :

H/W path Device Class Description

/0/100/1c/0 wlp1s0 network Wireless 8265 / 8275
/0/100/1f.6 eno1 network Ethernet Connection I219-LM
/2 virbr0-nic network Ethernet interface
/3 virbr0 network Ethernet interface

if you have it listed like in the above example ( eno1 is the ethernet ),

use this to see if it has IP :
ip a s eno1

Check eth cable on desktop, it’s fine.

Ran sudo lshw -class network -short with no results only header titles no data

So either you dont have drivers or its faulty. You can try to reinstall hiveos with the recovery command in console. And see if all work like it should

Thanks for all your help, really greatly appreciated.

2nd thoughts, maybe I should try reflashing the bios, if the power brownout corrupted ssd code, I suppose it could corrupt bios.

Nah i dont think poweroutage can corrupt the gpu bios. But you can test. I really dont think its that.

sorry, I meant the motherboard bios, this is a biostar it’s supposed to have built in protection, I’m really surprised this happened, the sad thing is it happen so fast it was hardly a flicker in the house, but I’m thinking when power came back in it surged slightly and caused the damage, also having trouble with psu’s inline to this rig.

Bios has backup power, a battery. But the psu might be a problem. Sometimes they get damaged

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.