Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Cpuminer missing zen2 and zen3 binaries and dependency problems

I just started using cpuminer on hiveos and noticed that the amd optimized zen2 and zen3 binaries are missing. I tried downloading them manually from cpuminer releases (same version 1.1.9) and replacing the binary started in the script Whenever I try starting it I get the following error:

./cpuminer-zen2: /usr/lib/x86_64-linux-gnu/ version CURL_OPENSSL_4’ not found (required by ./cpuminer-zen2)`

I am using the latest version 0.6-210@210928

How to fix that?

I tried running the binary manually and it works with no problems. So it must be a problem in the hiveos pipeline and how it sets the environment. Can anybody help?

1 Like

Would this help?

(Im on same spot, just with /usr/lib/x86_64-linux-gnu/ version CURL_OPENSSL_3’ not found`)

did u find a solution?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.