Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Could not find command prompt "echo" Please help :)

Hey All

So i have 2 miners, 1 with 6 1060’s and its running great on Hive OS, I have another with 7 1070’s, and i cannot get it to work. I tried multiple times and its always the same result. It starts up and you see it start loading, then it either goes blank or says “Could not find command prompt Echo.” I have tried with just 1 card, with 7, changed out network cables etc… I am really not sure what to do to get it working.
Any help would be amazing.

Thanks Kurt

literally same issue, ive reformatted and reflashed the OS. ive hard restarted everything a million times. I’ve noticed sometimes if i wait 2-5 min, it will just boot into HiveOS like normal but like more than 3/4 the time it just freezes on

error: can’t find command ‘echo’.
error: can’t find command ‘echo’.
Press any key to continue…
(if it lets me keep typing after pressing a key, i know it will boot normally)
idk did u get this solved i wanted to use HiveOs for its simplicity and efficiency but I cant if it wont boot…

Hi, I am running into this same issue. Were you able to find a solution? I was running hive fine for about a month and then all of a sudden I cant get it to run atall.

Have you tried hooking a monitor up to see what errors are displayed?

Yes, all it displays is that could not find promote “echo” twice. Its odd and ever since I can’t get my rig working properly.

That usually refers to a hardware issue where the system can’t boot properly. Make sure RAM, CPU, GPU’s are all connected correctly.

This is NOT a hardware error.

The issue is which partition your BIOS chooses to boot from.
Enter the BIOS and set it to boot from the non-UEFI partition. This resolved the issue for me.

Here is more info on troubleshooting:


Thanks a million!!!

I’m having this issue even with setting my boot to CSM

I tried CSM with legacy and UEFI enabled, I also tried all UEFI settings. Same result.

I see my rig being detected in my HiveOS mobile app. It says my amd athalon cpu is disabled, I have no cards installed at the rig yet for these tests.

Any ideas?

Interesting but correct!!!