Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Connect to wifi

Can somebody please explain step by step how to conect to wifi network
I try some solutions but no one work for me.
At the same time “wi dev” command and all command with “wi” don’t work

My rig :

[email protected]

Asus Prime Z490 P
Pentium Gold 6400
8 Gb Ram
SSD 128 Gb
GPU Nvidia 3060 4 psc

TPLink TL-WN725N

still the same answer,

follow the instructions here :smiley:

Well, until now I try this:

How to connect to a WPA/WPA2 WiFi network using Linux command line

This is a step-to-step guide for connecting to a WPA/WPA2 WiFi network via the Linux command line interface. The tools are:

  1. wpa_supplicant
  2. iw
  3. ip
  4. ping

iw is the basic tool for WiFi network-related tasks, such as finding the WiFi device name, and scanning access points. wpa_supplicant is the wireless tool for connecting to a WPA/WPA2 network. ip is used for enabling/disabling devices, and finding out general network interface information.

The steps for connecting to a WPA/WPA2 network are:

  1. Find out the wireless device name.

    $ /sbin/iw dev
    Interface wlan0
    ifindex 3
    type managed

The above output showed that the system has 1 physical WiFi card, designated as phy#0. The device name is wlan0. The type specifies the operation mode of the wireless device. managed means the device is a WiFi station or client that connects to an access point.

  1. Check that the wireless device is up.

    $ ip link show wlan0
    3: wlan0: (BROADCAST,MULTICAST) mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether 74:e5:43:a1:ce:65 brd ff:ff:ff:ff:ff:ff

Look for the word “UP” inside the brackets in the first line of the output.

In the above example, wlan0 is not UP. Execute the following command to bring it up:

$ sudo ip link set wlan0 up  
[sudo] password for peter:

Note: you need root privilege for the above operation.

If you run the show link command again, you can tell that wlan0 is now UP.

$ ip link show wlan0
3: wlan0: (NO-CARRIER,BROADCAST,MULTICAST,UP) mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 74:e5:43:a1:ce:65 brd ff:ff:ff:ff:ff:ff
  1. Check the connection status.

    $ /sbin/iw wlan0 link
    Not connected.

The above output shows that you are not connected to any network.

  1. Scan to find out what WiFi network(s) are detected

    $ sudo /sbin/iw wlan0 scan
    BSS 00:14:d1:9c:1f:c8 (on wlan0)
    … sniped …
    freq: 2412
    SSID: gorilla
    RSN: * Version: 1
    * Group cipher: CCMP
    * Pairwise ciphers: CCMP
    * Authentication suites: PSK
    * Capabilities: (0x0000)
    … sniped …

The 2 important pieces of information from the above are the SSID and the security protocol (WPA/WPA2 vs WEP). The SSID from the above example is gorilla. The security protocol is RSN, also commonly referred to as WPA2. The security protocol is important because it determines what tool you use to connect to the network.

  1. Connect to WPA/WPA2 WiFi network.
    This is a 2 step process. First, you generate a configuration file for wpa_supplicant that contains the pre-shared key (“passphrase”) for the WiFi network.

    $ sudo -s
    [sudo] password for peter:
    $ wpa_passphrase gorilla >> /etc/wpa_supplicant.conf
    …type in the passphrase and hit enter…

wpa_passphrase takes the SSID as the single argument. You must type in the passphrase for the WiFi network gorilla after you run the command. Using that information, wpa_passphrase will output the necessary configuration statements to the standard output. Those statements are appended to the wpa_supplicant configuration file located at /etc/wpa_supplicant.conf.

Note: you need root privilege to write to /etc/wpa_supplicant.conf.

$ cat /etc/wpa_supplicant.conf 
# reading passphrase from stdin

The second step is to run wpa_supplicant with the new configuration file.

$ sudo wpa_supplicant -B -D wext -i wlan0 -c /etc/wpa_supplicant.conf
-B means run wpa_supplicant in the background.
-D specifies the wireless driver. wext is the generic driver.
-c specifies the path for the configuration file.

Use the iw command to verify that you are indeed connected to the SSID.

$ /sbin/iw wlan0 link
Connected to 00:14:d1:9c:1f:c8 (on wlan0)
	SSID: gorilla
	freq: 2412
	RX: 63825 bytes (471 packets)
	TX: 1344 bytes (12 packets)
	signal: -27 dBm
	tx bitrate: 6.5 MBit/s MCS 0

	bss flags:	short-slot-time
	dtim period:	0
	beacon int:	100
  1. Obtain IP address by DHCP

    $ sudo dhclient wlan0

Use the ip command to verify the IP address assigned by DHCP. The IP address is from below.

$ ip addr show wlan0
3: wlan0:  mtu 1500 qdisc mq state UP qlen 1000
    link/ether 74:e5:43:a1:ce:65 brd ff:ff:ff:ff:ff:ff
    inet brd scope global wlan0
    inet6 fe80::76e5:43ff:fea1:ce65/64 scope link 
       valid_lft forever preferred_lft forever
  1. Add default routing rule.
    The last configuration step is to make sure that you have the proper routing rules.

    $ ip route show dev wlan0 proto kernel scope link src

The above routing table contains only 1 rule which redirects all traffic destined for the local subnet (192.168.1.x) to the wlan0 interface. You may want to add a default routing rule to pass all other traffic through wlan0 as well.

$ sudo ip route add default via dev wlan0
$ ip route show
default via dev wlan0 dev wlan0  proto kernel  scope link  src
  1. ping external ip address to test connectivity

    $ ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_req=1 ttl=48 time=135 ms
    64 bytes from icmp_req=2 ttl=48 time=135 ms
    64 bytes from icmp_req=3 ttl=48 time=134 ms
    — ping statistics —
    3 packets transmitted, 3 received, 0% packet loss, time 2000ms
    rtt min/avg/max/mdev = 134.575/134.972/135.241/0.414 ms

The above series of steps is a very verbose explanation of how to connect a WPA/WPA2 WiFi network. Some steps can be skipped as you connect to the same access point for a second time. For instance, you already know the WiFi device name, and the configuration file is already set up for the network. The process needs to be tailored according to your situation.


On the first step

  1. Find out the wireless device name.

    $ /sbin/iw dev
    Interface wlan0
    ifindex 3
    type managed

“iw dev” not working at all, also all command with “iw” not working.

Any solution ?

i am not sure why you use this complex method of doing nothing.
i already posted the problem which you get with your wireless device.
I also had this problem, at first it worked for some time then it stopped.
The problem was the inbuilt driver for wireless dongles.
i had to banlist it in the kernel and install the new one and at it to the kernel to load in on start.
All is in the link i shared with you in the previous post.

then you have to read what HiveOS provides…
if all the drivers are ok you just need to write in console : wifi
wifi command scans and displays a list with networks.
you just select the number in front of the network SSID and write password
or you can wifi SSID PASS
simple as that.

Thanks for answer, I 'll try with your method.

i have done this on minerstat OS and also in HiveOs so it should work with you too.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.