More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Claymore CryptoNote and often "Miner thread hangs"

After nicehash is down lot’s of complaints about Claymore X reboots.

The general idea is that it tries to mine on nicehash pool like

18:33:05:011    d8fe9700        DevFee: XMR: Stratum - connecting to 'cryptonight.usa.nicehash.com' <198.23.94.139> port 3355

which you can inspect in logs.

By default claymore will be mining devfee on the same pool, but for for coins like ETN when the “-allpools 1” option is set it will mine it on some default pools. And you can’t turn it off. Here is what you get.

????????????????????????????????????????????????????????????????ͻ
?         Claymore's CryptoNote AMD GPU Miner v10.2 Beta         ?
????????????????????????????????????????????????????????????????ͼ

Wrong Monero wallet address, "-allpools 1" option will be enabled automatically, read Readme for details.
XMR: 1 pool is specified
Main Monero pool is uk-etn-pool.hashparty.io:7777
At least 16 GB of Virtual Memory is required for multi-GPU systems

If you set “-nofee 1” it is reported that it’s more stable. But lower hashrate.

Recently added nicehash to /etc/hosts: 127.0.0.1 cryptonight.usa.nicehash.com

[email protected]:/hive/claymorex# cat lastrun_noappend.log | grep Dev
23:12:24:481	6e7dc700	DevFee: XMR: Stratum - connecting to 'xmr.suprnova.cc' <145.239.65.23> port 5222
23:12:24:529	6e7dc700	DevFee: XMR: Stratum - Connected (xmr.suprnova.cc:5222) (unsecure)
23:12:24:640	6e7dc700	DevFee: start mining (54sec)

Seems that worked. Though /etc/hosts is overwritten by hive every hour so that might be a temporary solution.