Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Cant update to last version

I dont know where but I fucked up. I cant update my rig. Due to permisions?

I tried updating via webgui.

Let me know If you know how to fix. Sorry for my poor research.


Hit:1 InRelease
Reading package lists…

Reading package lists…
Building dependency tree…
Reading state information…
Calculating upgrade…
The following packages have been kept back:
libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386
libwayland-egl1-mesa libxatracker2 mesa-vdpau-drivers
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 0 B/42.4 MB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database … (Reading database … 5%(Reading database … 10%(Reading database … 15%(Reading database … 20%(Reading database … 25%(Reading database … 30%(Reading database … 35%(Reading database … 40%(Reading database … 45%(Reading database … 50%(Reading database … 55%(Reading database … 60%(Reading database … 65%(Reading database … 70%(Reading database … 75%(Reading database … 80%(Reading database … 85%(Reading database … 90%(Reading database … 95%(Reading database … 100%(Reading database … 109293 files and directories currently installed.)
Preparing to unpack …/archives/hive_0.5-67_all.deb …

Stopping miner
Stopping screen session 4036
Unpacking hive (0.5-67) over (0.5-66) …
dpkg: error processing archive /var/cache/apt/archives/hive_0.5-67_all.deb (–unpack):
unable to make backup link of ‘./hive/claymore/11.9/config.txt’ before installing new version: Operation not permitted
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
chown: changing ownership of ‘/hive/claymore/11.9/epools.txt’: Operation not permitted
chown: changing ownership of ‘/hive/claymore/11.9/config.txt’: Operation not permitted
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Upgrade failed


Check attributes the file have:

lsattr ./hive/claymore/11.9/config.txt

It showed -i and -e attributes. After this I removed them.

Removed -i and -e attributes from the files:

chattr -e ./hive/claymore/11.9/config.txt
chattr -i ./hive/claymore/11.9/config.txt

After that I retry updating. Had a new error in the epools.txt file. But fixed doing this:

chattr -e ./hive/claymore/11.9/epools.txt
chattr -i ./hive/claymore/11.9/epools.txt

Final step was running selfupgrade and It worked.

Same issue here… unable to update my rig to V 05.67…

Lets hope someone can help us.

Fixed. Will update op with the solution @omikron13