More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Cant connect to lan or internet Gigabyte b660m mobo curle couldnt resolve host (6)

Hi,

trying to get a new rig running and it wont connect to net or even LAN. Error code "CURLE_COULDNT_RESOLVE_HOST (6) Couldnt resolve host. The given remote host was not resolved.

Ive tried ip scanner and cant detect the rig there.

ive tried

  • changing from usb to ssd
  • turning off, unplug ethernet, reboot, start up, plug in but nothing ( advice off reddit)
    -changing to google DNS
    -tried installing the ethernet controller drivers for linus off usb but failed
    -have 5.10 kernel

currently the rig has no gpus
also, never put updated the rig.config with rigs username and password, as i have just skipped this and put it in at start up (firstrun -f)

need some help please!

Silvagi

Does the drive work on other pcs and get a network connection? Can you post the results of net-test here?

Its the motherboard network components (not drive) thats not working in hiveos, I ran Ubuntu to test and it worked. Then tested windows 11 and it was held up at installation as did not connect, so i connected andriod phone via usb tether and downloaded the driver from gigabyte and YES its working but i want to use for HiveOS. Even took back to the shop I bought it and they tested it saying it worked (windows). I think and they think it needs drivers otherwise not working out of box.

Never had a motherboard not work out of box regarding its network card/ethernet

So, how can I install the correct driver for my MB? I did try last night but failed in doing so (too complicated+ bad info).

I believe I have a bulk driver downloaded from intel that covers the controller for linux/ubuntu (controller 1225-V from intel)

I have it on USB drive but not that good with Linux cmds…please give advice or link a guide on doing so.

Thanks for the help.

silvagi

Oh, “does the drive work on other pcs” i didnt test the drive but flashed the beta kernel too to check and didnt work either. I check again on USB drive same image and didnt work . Also I have another 2 rigs on same image running perfectly.

so its not the drives hardware i think.

Which specific image are you running? Have you tried the latest beta?

ive tried 0.6 217 and 0.6.210.

0.6.217 ive got two rigs running fine, using btc360 from bios star on both.

which image should I try?

Which specific kernel # have you tried? 5.10 prefix is used on 4 or 5 kernels

5.10.0 kernel hiveos# 110

where can I download image [email protected] so can flash a USB drive and try it. thats the lastest right? its not on the downloads page or gpu section in installer

That’s the latest script version, latest stable is still 220422. Try this beta http://download.hiveos.farm/test/hiveos-0.6-217-beta2%40220504.img.xz