More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Cannot get HTTP API bind to work with HiveOS?

New to hiveOS so sorry in advance if I missed something. I am mining using T-Rex miner and I want to be able to get HTTP API requests, below is the data I have put in the config arg section but it doesn’t seem to work?

Not sure if maybe hiveos has a firewall that would prevent me from accessing this? or if I am missing something?

2 Likes

Yes same here. seems like upgrading to latest OS version made the trex miner not honor the “api-bind-http” arg anymore. I had it set to 0.0.0.0 and diff port which i am forwarding through my router

It stopped working now and seems like hiveos is overriding this with its own setting for this specific argument.

I’m sure it’s not the problem with the t-rex miner version, as im running the same miner version in my other rig which is using Windows. the api-bind-http works there. so I can say the HiveOS latest version itself caused this new issue

Same problem! My setting is ignored and hive using its own!
In miner log:
20210428 10:40:15 ApiServer: HTTP server started on 127.0.0.1:4059
20210428 10:40:15 ---------------------------------------------------
20210428 10:40:15 For control navigate to: http://127.0.0.1:4059/trex
20210428 10:40:15 ---------------------------------------------------

But in User Config of Flight Sheet was:
“extra-dag-epoch”: 0
“worker”: “%WORKER_NAME%”
“api-bind-http”: “0.0.0.0:4067”
“dag-build-mode”: “2”

HiveOs:
[email protected]

=== /hive/miners/t-rex/0.20.3/config.json ===

“api-bind-telnet”: “127.0.0.1:4058”,
“api-bind-http”: “127.0.0.1:4059”,
“json-response”: true,
“retries”: 3,
“retry-pause”: 10,
“timeout”: 180,
“no-watchdog”: true,
“algo”: “ethash”,
“hashrate-avr”: 30,
“log-path”: “/var/log/miner/t-rex/t-rex.log”,
“exit-on-cuda-error”: true,
“exit-on-connection-lost”: false,
“extra-dag-epoch”: 0,
“dag-build-mode”: “2”,

Well I switched to minerstat to see if it also had the same issue and I couldn’t get the bind-http working on t-rex. So I guess probably doing something wrong lol

Up ! Solution please

Still not decided

It’s not your settings, I have the same problem and until recently the arguments you have worked. I hope this is eventually fixed.

1 Like

Anybody known how to fix this?

1 Like

Would love to know as well. Losing the API sucks when it’s such a great tool for monitoring from a cell phone. Hive OS will not not let T-Rex change the API IP and Port.

Works just fine in Windows though.

HiveOS, you cannot force the setting to 0.0.0.0:4059 with read only argument ?

/hive/miners/t-rex/h-config.sh
I believe It was hard coded to listen 127.0.0.1 because local os will get statistics data from it and upload to hiveos.farm. If you know what you are doing, the simple solution is to change it to 0.0.0.0, then you can access the web api by visiting your rig’s lan address.

3 Likes

Anybody have found a way to make it work ? With the new LHR dual Mining I would like to see the api from t-rex I use to use it in windows and with Hive its usually not needed but now with the dual coin mining not beeing seen in Hive its would be usefull…

gokeeper Was correct. It’s now hardcoded to 127.0.0.1 in the shell script so the flight sheet parameter is ignored.

@Frank_TheRock @epicwin

You can fix this by connecting to the machine over SSH or the remote hive shell from the browser and running this command. It will replace 127.0.0.1 with 0.0.0.0, allowing it to bind to your IP address again.

sed -i 's/127.0.0.1/0.0.0.0/g' /hive/miners/t-rex/h-config.sh

You can see the output with this command

tail /hive/miners/t-rex/h-config.sh

Then make a change to your flight sheet, any change, so that the config for the miner is regenerated using our modified script.

4 Likes

Ho great it work!! It was less of an issue since Hive Have had the dual Hashrate viewer but I will still use the t-Rex miner UI I like the layout!

thanks a lot @ApocalypseCow !!! :beers:

Can u show where to run these commands and what to type in the flight sheet?

I had to do the following for TeamRedMiner:

sed -i ‘s/127.0.0.1/0.0.0.0/g’ /hive/miners/teamredminer/h-run.sh