Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Can’t Start Miner, Can’t initialize Cuda engine, is Nvidia driver installed error

Hey Hive,

Setting our first rig. I am getting an error message

Not sure if the picture uploaded.

Error - cant start miner, can’t initialize Cuda engine, Cuda exception in [main, 609], Cuda_error_no_device. Is Nvidia driver installed.

Any suggestions. Thanks

hello, did you fix it<<< becuase im havind the same problem and i dont know what todo thanks

i have the same problem , I’ve been trying to solve it for one day …

i have the same problem

I got the same error with GeForce RTX™ 3080 GAMING OC WATERFORCE WB 10G
I am not sure about root cause is the rtx 3080 cannot without “Fan” or it will overheat, then disappear in the hiveos even the OS also hang up(All you can do is poweroff).

So I think is possible hiveos doesn’t have nvidia driver for waterforce?
If any body find the solution, please share to us.

Following have the same problem

I got the same problem and looking for solution

I got this error also, and fixed it. Seems like you’re using flash drive, try replacing it or change to SSD. Also if you’re using 30 series cards, use 455 nvidia drivers. This error occurs to me when I updated to 460 one’s.

I went and returned the rigs that I had purchased as the seller could not help with any software patches. I got another rig (s) and as is well.


I am getting error as in snapshot… Can you suggest a way forward. Using 3060 card.