More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

C-mode TeamRedMiner

New to HiveOS. I have a Radeon vii Hynix and been trying to activate C-Mode in TeamRedMiner but with no success. There doesn’t seem to be much literature out there for troubleshooting so hoping anyone here can assist. I’ve tried some editing per a RedPanda video i saw and i wasn’t able to update the grub when changing the blocksize. if you google redpanda 100 mh/s radeon vii it’ll pop up. Others seem to be having success but using different OS’s or programs in linux. I really like HiveOS so i’m trying to stick with it. I’ve messed with some other versions of the OS as well still no luck. If anyone has any ideas it would be greatly appreciated. Thanks!

HiveOS vers. [email protected] GPU version
Driver 20.40
TeamRedMiner 0.8.1

Did you manage to activate c-mode?

Did you activate Cmode?
i can help you

I assumed you followed this guide? I had no issue following it and getting my R7 rigs to run in C-mode. Make sure to run update-grub after editing and saving the grub file (same as update-grub2 for me).

Following any HiveOS update, you must edit the grub file once again to increase the block size, as HiveOS re-updates the grub file after every time a new version is installed.

However ignore the part about enabling GUI and editing the xinit.user.sh file to apply the memory timing tweak. HiveOS released an update recently that adds support for amdmemtweak right in the HiveOS dashboard next to your clock and voltage settings.

hi,
cant update-grub2 keeps saying syntax error line 54

Most common error is with the " " in this step of the process edits:
GRUB_CMDLINE_LINUX_DEFAULT

  • amdgpu.vm_block_size=10 amdgpu.vm_size=1024

Have you double checked that portion before running the update-grub2?

ya i put the " at the end but gives me error on line 54
ok i manage to update it after doing the same thing but this time it updated.
I believe my error was when i copy past “amdgpu.vm_block_size=10 amdgpu.vm_size=1024"” this i pressed space before amdgpu and now i copy pasted " amdgpu.vm_block_size=10 amdgpu.vm_size=1024"" that space instead of pressing on nano being copy/pasted i believe it made the difference.

I have had bad luck pasting in the VIM or Nano interfaces, so I just type it in manually.

Glad to hear you got it working, happy mining!

1 Like


from 87mhs to this stable

1 Like

careful with the hynix card.