Increase your income with Hive. Invite your friends and earn real cryptocurrency!

BTC T-37 only 6 GPUS detected

Hey folks,

I’m wondering why, suddenly, my motherboard BTC S37 won’t recognize 8 GPUs as it supposed to.

I tried differents PSU, and no matter what, even when changing the cables, it will show only 6 GPUs.

For a reason I ignore, when I plugged another PSU, a GPU was detected and when I rebooted, it disappeared.

Did anyone face the same issue ?

It happened when I changed a GPU, and upgraded HiveOS (I tried to downgrade but i doesn’t change anything)

It’s not showing on HiveOS but the lights and the fans work

Thank you

Hi there,
I have the same mainboard and 8 gpu and use this adapter from Amazon:
( Xhwykzz mit zwei Netzteilen 24-poliges Verlängerungskabel für ATX-Motherboard, 24-polig bis 24-polig (20 + 4), 12 Zoll / 30 cm Schwarz)
I use a power supply for the 6 pin connections on the mainboard and the second power supply for the graphics cards


IMHO I don’t recommend to use separate PSU connect to each GPU (riser and gpu pcie, in this case mobo pcie and gpu pcie). You might damage your gpu and might impact outlet as well…
There is several discussions at reddit related to this topic.
Also, I’m not sure you are using S37 or T37 but, if you are using S37, I don’t recommend to use multiple PSU unless you use risers. This has been discussed at reddit as well.

Have you removed GPU and put them in a different slot? My mobo seemeed to remember where I put cards so I had to make sure I put cards in slots already used otherwise when I tried putting an additional card in and a slot I had used before was empty it did not recognise the new gpu.

I tried without success

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.