Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Boot issue with HiveOS - black screen after grub

After deep research on a fix I come to you for help…
I’ve been running 2 3060ti and 2 3070 on a mb MAG B460. Everything was running fine booting from SSD until it just stopped booting and no post for god knows which reason.

Things I tried :
-Plugging a monitor to mb / PCIe 16x slot / other PCIe slots
-Removing the cards 1 by 1 to checking if it boots each time, doesn’t change a thing
-Unplug/plug SSD
-Unplig/plug ethernet cable
-Unplugging/Plugging CPU power cable / reinstalling CPU in the slot
-Flashing a USB drive with fresh downloaded HiveOS image → here I get to grub, black screen after that
-Booting HiveOS from the USB in recovery mode → I get a weird shell saying: “could not find command ‘echo’ press any key to continue” gets frozen after pressing a key
-Switching of USB port on mb
-Testing the flashed USB on different machine (running BIOS), works fine but I need to boot on the non-UEFI partition of the drive for it to work

UEFI settings:
-Enabling Legacy USB support
-Changing PEG0 - Max link speed to gen1 or gen2
-Changing UEFI settings to CSM and PCE → ez debug leg on mb stuck on VGA, freezes and needs CMOS to even get access to the UEFI
-CMOS → booting from SSD = no post
→ booting from USB = grub, then no post

Here I’ve tried all combinations of the above.

I can’t seem to be able to boot from the non-UEFI partition of the flash drive on this machine, I only get to choose between 2 UEFI partitions that are both not booting.

Any lead would be truly appreciated.

I have the same issue. Need guidance too

I don’t have a clue on how to proprerly fix this but I figured my SSD was dead (it was a M.2 SATA SSD). I tried with another SDD plugged with a SATA cable to the motherboard + PSU but that didn’t work either.
The only fix that did it for me was plugging the new SSD with my SATA to USB adapter on one of those USB 3.0 ports on the motherboard (with legacy USB enabled in BIOS) and then it works. I still don’t get it but at least I found a way around.
Still haven’t been able to recover my dead SSD tough.

I hope that helps you in any way.

I tried to change my SSD. And the problem was solved. Thanks

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.