More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Black screen after Grub Boot Selection

Hi guys,

One of my working rigs, stopped today and after restart it wouldn’t boot again. BIOS settings are the same, it works fine but after BIOS screen, GRUB screen comes, it counts to load HiveOS and then nothing happens but a black screen. After about 5 mins of that black screen it restarts itself. I can’t see anything so I don’t have any data to give. If I choose advanced options in the GRUB it says there’s no command line ECHO and another almost blank screen waits in the screen.

The system is installed on an HDD, after this failure I tried to install and boot from a fresh USB storage but it happened again. I’ve changed the SATA cable and its position but still the same. I don’t understand what happened but it seems to be some kind of Hiveos failure again and again.

Please somebody help me.

Thnx in advance.

PS: The OS version is [email protected] and normally it works fine for this rig.

Test the drive on another rig, and a known working drive on that rig. Narrow down the issue.

Also, flash the latest stable image and troubleshoot from there.

The problem is HiveOS’ driver support is rediculous as you stop supporting in some updates without mentioning. We have to find the right kernel and OS combination.

By the way I’ve solved it as such:

  1. Only [email protected] build supports for USB dongles
  2. 5.4 kernel supports both Ethernet and USB Wifi connection
  3. 5.10 kernel supports USB Wifi but doesn’t support Ethernet.

So you should install [email protected] and update to [email protected], this way kernel stays at 5.4 but driver support improves.

This is happening because of the chipset support of HiveOS, you stop supporting without mentioning, sometimes older version supports but new versions doesn’t and visa versa. Logically, after supporting, the consequent versions must keep supporting, but you don’t. Interestingly a working rig may become useless as you stop API support without mentioning. The rig stoppped and couldn’t boot again because of that thing. I couldn’t solve it until I find the right combination. HiveOS should stop this, we are paying for the service.

By the way, my motherboards are Biostar BTC 360 Pro and v2, and ASUS ROG B550A.

All my wifi dongles have Realtek chipset inside.

All are very common chipsets but the software doesn’t support in some builds.