Increase your income with Hive. Invite your friends and earn real cryptocurrency!

B75USB / b75 usb motherboard BIOS and troubleshooting

Hey miners! I’ve got a few B75USB (unbranded) motherboards from China. I’m having some issues with setting up that old BIOS. For the references - here’s how it looks:

Problem number one. After running amd-info I can see that at least 4 GPUs are not taking my OC settings. Based on the layout of this mobo I feel like they took one PCIe x16 and split it by 8 USBs or something like that. I can’t figure out the proper BIOS settings for this junk. Did anyone happen to solve this?
Problem number two. I need to find BIOS update for this mobo. I hope it does exist and it could solve some of my problems (fingers crossed).
Appreciate your help!

I’ve this same MB.
I’m unable it to detect any GPU. Is there any special BIOS configuration?
I’ve tried to change PCIe speed Gen1/Gen2, but nothing changes.
I’m trying it with two AMD RX6700 GPUs.

Thank you

Check your 8-pin power on GPUs. Once I was “troubleshooting” for hours before I realized my GPU is not plugged into the power supply. If that’s not an issue do the raisers’ swap and make sure raisers get the lights on when you power on your rig. Order a new set from another manufacturer. Cheap raisers always cause a lot of issues.
If still nothing - send the mobo/CPU back. I’ve done an endless amount of hours trying to make Chinese B250 to work and not freeze - now doing eBay case to send it back since it’s junk.
BTW they got the newest edition now, which has M2 SSD on it. That one supposes to be more stable since it’s got more capacitors around the CPU and an updated design with additional 6-pin power by the USBs. If you don’t wish to mess with boards like I do get Z390/Z490 and any CPU that fits and buy a 1 to 4 x1 adapter if you need more than 5 GPUs.


Thank you for your answer. I’ve the GPUs powered. As well as the riser (it has the leds on). I’ve tried two MB, one is the 8 PCIe to USB and also the 12 PCIe to USB. I’ve also tried with two GPUs and two different risers.
I’ve tried pluging the USB cable on different USBs.

Thank you

If you still don’t see one or both GPUs I’d say test them in Windows and see if they’re working or not. Could be dead GPU.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.