Increase your income with Hive. Invite your friends and earn real cryptocurrency!

B250 mining motherboard

Hello all,

I have a b250 motherboard and i have using it for 3 months now, suddenly a issue showed up i cant get my display on my tv or monitor nothing.

I have tried removing all cables and fix new psu cpu and ram and still doesnt work.

When i start it the cpu fan spins and nothing shows up in the monitor black, different monitor same problem.

Any help from anyone please


Hi. I assume you are talking about your onboard video port. Are you able to tell if the MB is not posting or if just your vid port is dead? It could be booting but you just cant tell. Did you know your IP address before this occurred? If so, can you ping it or can you locate the device in your router? Are you getting the same no vid condition when you use a discrete gpu (without risers)?


Yes the video port seems faulty or something is wrong and i have tried with gpu and without same problem.

I can turn it on and the cpu fan spins but no display on the monitor.

I disamble the parts its not connet the router to identify the ip address

What OS is installed? If after you power it on for a while and it powers off as soon as you press the power button again, its either stuck in bios, or the MB is not posting.

Mb not posting, i have win10 or hiveos not showing both

Having dealt with the b250 mining snob for several years ( I own two but only use one at a time. ) I’ve learned that if you’ve tried all the things you’ve mentioned above; (and trying running hiveos on a different media/reflash) and its not your PCI-X risers, sounds like its broken or you’ve overloaded your electrical circuits. Maybe take a picture of it? Did you plug in the molex connectors into the motherboard? (DONT) I read somewhere this can brick your motherboard if you do so in conditions where its not recommended (I believe if you are using less than three graphics cards, you ‘need’ the molex connectors.) I’ve never run that few so I cannot confirm that but I remember reading about it in the manual and being confused.

I myself have had this problem many many times and I never really truly figured out what triggered it, but it somehow resolved itself after letting the thing ‘rest’ for a few days. But I’ve learned when this happens its a result of a combination of things stemming from me being lazy about my cable management, improper power balancing, mismatching power supply connections (using PCIX power from psu A and riser power from PSU B) and properly managing airflow.

I’ve set my mb on fire with a improperly plugged in pcix slot, melted the slot, but the motherboard still works fine (just not the burnt/melt port or hey maybe it would but I dont want to chance another fire) So maybe theres something up with your electricity cause these boards are tanks.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.