Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Audio drivers for HiveOS?

Hello I currently use HiveOS to mine eth using one Rx580. The OS comes with firefox preinstalled and I want to be able to use it to watch youtube but there is no sound. I’m guessing there are no audio drivers since you don’t need them for mining. Am not good at linux so does anyone know how to install audio drivers or get it work?.

1 Like

Here I found this as I also didn’t find it on HiveOS and I didn’t seem to find it on google easily. I wanted to mine with my work pc and when I want to watch youtube videos or play music or hear notifications I couldn’t and I really liked using linux to mine far better results so here:

Open your terminal and copy and paste this line of code:
“sudo modprobe snd-hda-intel”

After you pasted this code copy and paste this line of code:
“lspci -nnk | grep -A2 Audio”

This will display a list of your audio hardware.

Now paste the following code:
“pulseaudio --check”

Than paste this:
“pulseaudio -D”

You will get a message like this:
“W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).”

After this message paste this code:

Now pulse audio controller will open.

Before this with all the codes I have tried it didn’t work and the “pavucontrol” when I tried to open it, it was opening the controller and also “Trying to establish connection with pulse audio. Please wait…” and it never went a step further than that and it stuck on the same screen. Now with all of these commands you wont get that and your audio hardware will be detected and the sound will work and the dummy card will be removed.

I hope this will help you as it helped me. I looked through a lot of websites even on HiveOS I almost gave up and return to windows but luckily it worked this time.


Thank you so much I cannot thank you enough mate…!! :smiley:

now none if this works afer a restar i could cry huhuhh

what is your sound card diver ? you should install the your own card diver .
the @Burtrim solution just work for intel CPU’s that have embed sound diver chipset.

it was working ealier now it just says

1 Like

good luck for u :slightly_smiling_face:

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.