Increase your income with Hive. Invite your friends and earn real cryptocurrency!

ASUS PRIME Z-490-A Motherboard BIOS Settings x6 GPU Help

Hi, hope someone is able to help with this. I have a rig using a ASUS PRIME Z-490-A motherboard. Mining has been working great for about two weeks now with the Linux OS. I currently have x3 Nvidia 1080’s attached to the board via risers. Unfortunately, I have encountered a problem when adding a 4th card. The rig refuses to boot with the 4th card plugged into the board. If I then disconnect the 4th card, no problem, the rig fires up as normal. I have checked all the BIOS settings I can think of for this board, and have made the recommended changes for mining. However, the problem persists. I tried switching PCIe lanes multiple times, but this makes no difference either. 3 cards works, 4, or more cards, no go!

Is there anyone out in the community using this board, or another ASUS PRIME board with the same issue? Have you been able to get 4 or more Nvidia cards running? Please share your fix. I would greatly appreciate it!

1 Like

check this

I appreciate the reply. Unfortunately my BIOS version is different than the one shown in this video. I have version 2.20.1276. This is the latest right from ASUS.

Also, couple other things:

  1. My mother board is the ASUS PRIME Z490-A (not Z270 shown in the video)
  2. My OS is Linux (not windows)

check BIOS manual.
Try find such things:

  • PCI-E / M.2 slot sharing notice
  • Check 4G Above decoding
  • Try enable CSM support (if it present ob BIOS)
  • Turn off devices that does’t help in mining … e.g. Onboard HD Aduio

Yes sir. All those settings have been made. Works great with X3 GPU, but no boot with X4 GPU.

I think maybe a problem with motherboard like this:

Speed of PCI x16 slots will run at x8 / x8 / x4 but the excess will only run at x1 which causes the issue.

Can anyone confirm for me please, is there a problem trying to run more than X3 GPU with this board?

Thanks for your suggestions so far.

If I had to place a bet, I would say above 4G is not enabled (btw, I’m running 14 cards rigs on this card, so it can do it allright (you just have a boot issue after 10 cards or so, where you need to manually launch))

Yes, I reset and then set this to enabled at least 4 times already. 4G is set in the BIOS.

Are you suggesting that the 4G is not being set on the board, despite it being set in the BIOS?

If you have this same board, then you are using splitters . I’m going to try splitters off the first 3 slots only, and see if that makes a difference.

Thanks for your reply.

Hi Dude, did you solve the problem? I got exactly the same issue as yours. I have a ASUS PRIME Z490-P, and 2 3060Ti and 2 3080, the system doesn’t boot with the 4th card (even no video output and no bios information) and works quite normally with 3 cards.

1 Like

Pekoe, both yes, and no. I will explain the no part at the end.

  1. Make sure you have lots of power. I did away with my ATX power supplies, and now have two Server PSU’s hooked up. One is a 1500 watt, which is powering 6 cards and 6 risers. The second is a 1200 watt, which is powering my board, and the seventh card and its riser. No, this is not a typo, and yes, I am running 7 cards on my Z-490-A. I installed a 2 pole, 30 Amp electrical so that I can have 220V supply. Both PSU’s are plugged into a 30A PDU. This allows full 2700 watts of combined power, lots of head room for this rig. BTW, for clarity, I am running all 7 cards identical EVGA 8G 1080 FTW.

  2. When powering your board, make sure you have power to all power connections, including any of the peripherals if your board has them, even if they are not required by your particular setup. My Z-490-A has an additional 4 port plug right next to the 8 port CPU plug. Make sure you supply power here as well, if your board is the same.

  3. RAM, make sure you have enough. I have been told that 4GB is enough for mining. Nope, not for this setup. Start with 8GB, and check at boot if this is enough for you. I have X2 8GB installed on mine.

  4. BIOS. I updated mine to 2004 01/13/2021, which was the latest at the time of my original post. Your board may have a different version. I did this right from the beginning, because the latest version has additional support for Nvidia 30 series cards, which I plan to run later once cards are more readily available, and don’t cost the price of a used Toyota. Check this for your board as something you may want to do as well, especially because you have 30 series cards.

  5. BIOS settings. Here is where things get interesting. I have come to learn that some of the usual recommend settings for mining boards really don’t make any difference on the Z-490-A at all. Here we have a cap:
    a. Set default factory optimized, before making any
    Additional changes. On my board, this is F5

    b. Advanced / Platform Misc Config:
    - PCIe Native Power Management / Disabled
    - DMI Link ASPM Control / Disabled
    - ASPM / Disabled
    - L1 Substrates / Disabled
    - PCIe Clock Gating / Disabled
    - DMI Link ASPM Control / Disabled
    - PEG - ASPM / Disabled

    c. Advanced / CPU Config / As Is

    d. Advanced / System Agent (SA) Config:
    - VT-d / Disabled
    - Memory Remap / Disabled
    - Graphics Config / Primary Display / Auto
    - iGPU Multi-Monitor / Disabled
    - DVMT Pre-Allocated / 32M
    - RC6 / Enabled
    - PEG Port Config / Link Speed / All Set to Auto (I
    know, others will tell you to set gen 1, or gen 2.
    I’ve tested this on this board extensively. Setting
    this makes no difference on this board, so I just
    leave it set to Auto and it works no problem at

    f. Advanced / PCH Config:
    - PCIe Config / Speed / Auto (again, setting gen 1,
    or gen 2 makes no difference at all.

    g. Advanced / PCH Storage Config / SATA Controllers
    / Disabled

    e. Advanced / PCH-FW Config / PTT / Disabled

    f. Advanced / Thunderbolt / Leave as is

    g. Advanced / Subsystem Settings:
    - Above 4G Decoding / Enabled
    - Re-Size BAR Support / Disabled
    - SR-IOV Support / Enabled

    h. Advanced / USB Config / Leave as is

    I. Advanced / Network Stack Config / Leave as is

    j. Advanced / NVMe controller / Leave as is

    k. Advanced / Onboard Device Config:
    - PCIe Bandwidth Config / Auto
    - HD Audio and any lights / Off
    - Leave everything else as is

    l. Advanced / APM Config:
    - Restore AC Power Loss / Power On
    - All else / Disabled

    m. Advanced / HDD/SSD Info / Leave as is

    n. Boot
    - CSM / Disabled
    - Secure Boot / OS Type / Other (I’m Linux)
    - Key Management / Default
    - Boot Config / Fast Boot / Disabled
    - Boot Logo / Auto
    - Post Delay Time / 5 sec
    - NumLock State / On
    - Wait For F1 If Error / Enabled
    - AMI Native NVMe Support / Enabled
    - Option ROM Messages / Force BIOS
    - Interrupt 19 Capture / Disabled
    - Setup Mode / Advanced
    - Boot Sector Recovery / Local User Control
    - Next Boot Recovery / Skip

    m. Tweek you fans as desired.

I know, I know, very detailed and lengthy explanation. However, I have done so many settings getting this thing up and running with 7 cards, that I’ve forgotten most of them along they way. This way, you have a complete list, just in case I miss anything.

Also, my goal is to run a total of 8 cards on this board when I am done. I am using a PCIe lane splitter to achieve this in both x16 slots, so that I have 2 risers running off of each of the splitters. All the rest remain a single lane risers.

And now for the no part I mentioned in the beginning. You know in windows we can do a manual set for virtual memory by going into the advanced performance settings and giving as much as the disc will allow. I have been told to increase this for best performance. However, unfortunately, I do not know how to set this in Linux. Why I mention this, is because I believe I have a usable memory shortage to the cards. The best I am able to achieve is 30.xx average MH/s each card with 7 cards. When I was running 3 cards only, I was able to achieve 35.xx MH/s no problem. Once I added the 4th and beyond, anytime I try to push for higher than 30.xx, I get a minor crash/stop. I believe it is related to not enough mem, but not 100% sure. If you encounter this with your setup, let me know. Are you using Linux? Maybe you know of a solution to this as well…?

I hope you find this useful. Best of luck with your build.


oh my god… thanks for your so detailed information!
It seems that I met most of the requirements that you suggested, but I will check it out one by one later…
I think the power supply that you mentioned might be the most interesting part, although I already had 2 PSU(1300w+1200w) which I thought it was quite enough for my 4 GPUs, but I do connect 2 GPUs on each PSU, and one of 2 PSUs should also provide power for the motherboard. Is that possible the motherboard consumed much more power than we expected? I also don’t think the problem is from other settings of bios, for I can’t even access the bios configuration. The motherboard was totally down after I connected the 4th cards(any one of them). I will try again, great thanks!

Hi all,

I hope you are doing fine!

Well I have done all that An9elo_RZ said and the OS did recognize all 5 cards, but the miner didn’t stared complaining about some CUDA CORE error in the hive OS.

I have the same MOBO but my Above 4G option is in a different option, it is under Advanced / System Agent (SA) Config.

I tried a couple of things and strangely, just setting the BIOS to factory settings and disabling Above 4G fixed the issue.

PS: My rig worked fine with 4 GPUs (3 in risers and 1 into the 16x slot) and adding the 5th one in a riser messed up the first time.

PS1: I am waiting for another 2 risers to remove the GPU from the 16x slot and put it in a rise alongside with another GPU in the other rise, I will let you know if everything went well in a week.

Here is an update for anyone wondering if these ASUS boards are capable of running 8 GPU’s.

My Z490-A is now happily running 8 cards with no issues at all. Settings remain as previously posted, other than I dropped down to using 4GB of RAM.

Here are a few picture showing how I use PCIe splitters on the board to increase the GPU capacity.

Hope someone will find this helpful. Happy Mining!

And here I have another 8 cards running off of an ASUS B460-PLUS. Similar settings in the BIOS. However, in this case I must have the splitters inserted in the x16 PCIe slots, as they will not be detected otherwise.

Share and copy link to this thread for anyone needing help with these boards. Happy Mining all. Stay safe!

Hi, thank you so much !
You solve my problem !!
Thanks again :wink:

Hi, I am quite worried. I have an asus prime z490-p. I tried all this configuration and I can’t get it to work. I have a rx 6700 xt and 3 RX580. when I connect the fourth card it doesn’t work. :expressionless:

Hi guys,

I am back with good news, I have installed my sixth GPU and all of them still works.

Is it not because of your PSU, does It handle all the wattage of your GPUs? I did not have any problems with 4 GPUs (03 with risers and 01 in the PCIe 16x slot).
Did you try what I have said in my first post in this thread?

I have two 600w PSUs, should be fine. I tried your configuration but it didn’t work.

I created a forum account to say thank you for the detailed reply.
This helped me a lot.

I too had the same issue, 4 cards work but after adding the 5th card, the board boots to the BIOS and waits. Not sure which option fixed the issue but it’s working fine now :slight_smile: