Increase your income with Hive. Invite your friends and earn real cryptocurrency!

ASUS B250 network connection issue

I am trying to setup new rig. I have downloaded latest stable image 06.39 but can not connect to to register the rig. The rig continuosly requests new IP from DHCP server and can not use any route. Please advise how to troubleshoot.

After some additional investigation I am pretty sure the issue is HIVE OS related. The rig was able to connect to ASUS internet BIOS update and confirm that the latest BIOS is installed so I believe that hardware is operational. I detached all GPU to rule out any related problems. No changes. Troubleshooting suggestions will be appreciated. If you have B250 up and running please share what HIVE image are you using.

I received a suggestion to change networking driver. Something like sudo dpkg -i r8168-dkms_8.046.00-1_all.deb
echo “blacklist r8169” | sudo tee -a /etc/modprobe.d/blacklist.conf
Looking into it.

Need to find proper Intel I219-V driver and how to install it without network access. Realtek driver do not fit (and should not :wink:)

I found a guide how to get I219-V up and running
Here’s a detailed guide Ubuntu 18.04.1 LTS- support for Intel I219-V

  1. Download driver from (Testet on version
  2. Unpack zip to folder of your choice
  3. Change to the driver src directory,
    e.g. cd e1000e-
  4. Make sure that any older e1000e drivers are removed from the kernel before loading the new module sudo rmmod e1000e
  5. Compile the driver module: sudo make install
  6. Load the module using the modprobe command: sudo modprobe e1000e The binary will be installed as: /lib/modules//updates/drivers/net/ethernet/intel/e1000e/e1000e.ko
  7. Verify that the interface works. Enter the following, where IP_address is the IP address for another machine on the same subnet as the interface that is being tested: ping
  8. Make the driver persistent sudo dpkg-reconfigure linux-image-$(uname -r)

I think this is what pkt 8 does::… Note: For certain distributions like (but not limited to) RedHat Enterprise Linux 7 and Ubuntu, once the driver is installed the initrd/initramfs file may need to be updated to prevent the OS loading old versions of the e1000e driver. For Ubuntu: # update-initramfs -u

Going to try.

The latest available driver from Intel Version: (Latest) Date: 5/17/2019 compiled without errors but to no avail. Still no network connection, producing rather strange network diagnostic. I am out of ideas as for now :frowning:

Users of the same e1000e Intel network adapter experienced problems earlier. Going to check the solution. When miner hangs , the rig hangs and kills my switch

The issue was resolved with image based on UBUNTU 18.04 LTS ([email protected]). Kernel 5.0.21-hiveos

can anyone help me?
I have an Asus B250 Mining Expert motherboard and I can not connect to the Internet.
I connected a cable in LAN port.
I updated the BIOS.
And I checked that ONBOARD DEVICES LAN is running.

I do not know what else can be done. Can anyone please help me?

Please check what OS version are you using. 16.04 - based images have problems with e1000e Intel adapter. I expect current stable image to perform well but I can not confirm it, my B250 is offline as for now.

Check this : image

Hello everyone,

Still having the same issue on 5.0.21-201105-hiveos A OpenCL 20.30
Couple of my rigs killed my switches and the error on one of them I found:

[118944.780015] e1000e 0000:00:19.0 eth0: Reset adapter unexpectedly

Any other ideas how to manually set some cronjobs for the rigs start up ?
found this solution:


Disabling only TCP Segmentation Offload (TSO) does the trick for me.

ethtool -K eth0 tso off

Need to find a way to make every rig run this command on start up. And see if it helps.

Kind regards

found a lot of my rigs even with the newest hiveos kernel still use old e1000e driver wrote an ansible script to update all of my rigs e1000e driver so will see maybe the newest drive will help with the situation

if anyone needs this this is my script for checking current verion of your e1000e driver and updating if need be:
ansible-playbook --ssh-common-args ‘-o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null’ -i inventory main.yml


  • name: Update ethernet driver
    hosts: host
    remote_user: root


    • name: Check driver version
      shell: “ethtool -i eth0”
      register: ethversion

    • name: Run ethernet driver updater
      shell: “cd /hive/opt/e1000e && ./”
      register: dbgplz
      when: ethversion.stdout != “3.8.4-NAPI”

    • debug:
      msg: “{{ dbgplz }}”

    • name: Check driver version again
      shell: “ethtool -i eth0”
      register: ethversion_new

    • name: assert if bad
      that: ethversion_new.stdout == “3.8.4-NAPI”
      fail_msg: “Oh noz not good version”



EDIT: 2021-01-11 14:34 GMT+2

After all the updates still had the same issue one hour ago all rigs were down because one of them was not responding next would be to try the new stable image with the latest drivers. Or any other suggestions from the team and community.

Kind regards

IM having a similar issue but with a different MB. Z270. Basically once one goes down it takes the other with it. need to restart both. Seems to happen after 12 hours or so. Randomly.

I am having a similar issue with the b250 mining expert. I have 4 rigs, and one will end up jamming the network and taking out my entire network, internet included. I can’t even connect to my router unless I unplug the rig in question. I don’t know what to do and things have not got any better. I can’t use the rig cause it kills everything. It seems that the rig in question makes the light on the switch blink very fast and until unplugging it, nothing works. I can restart the rig and it works for a random amount of time. Please help, any info would be helpful.

I have updated the network card as well as running the latest bios.

The new update .6-196@210201 solved my issues.

Still having the issue

You could try getting a USB to RJ-45 and disable the onboard Nic and see if the issue persists.

Also have you checked the router for any logs/errors or any firmware updates?