Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Asus B250 / Asrock H110 e1000e NIC hangs entire network [SOLUTION]

Here is the solution to e1000e NIC problem used in Asus B250 motherboard and Asrock H110 Pro BTC motherboards. The Intel e1000e NIC has a bug where it dies unexpectedly and kills the entire network. I have been trying to resolve this issue for a long time, so here is the solution to this:

  1. update the NIC driver to the latest or use the v190 stable HiveOS image which provides the latest driver version.
    type in:

  2. to check you have the latest driver: use this command: ethtool -i eth0
    which will tell you the version and 3.8.4-NAPI is the latest as of this post

  3. Disable TCP-segmentation-offload and generic-segmentation-offload by modifying the /etc/network/interfaces
    type in:
    nano /etc/network/interfaces
    add this command to the end of the file
    post-up ethtool -K eth0 tso off gso off
    NOTE: post-up allows this command to be executed next time you startup, if not then you will lose this feature. -K must be a capital K.
    hit CTRL+O to save, hit enter to save into the same file
    hit CTRL+X to exit

  4. reboot the pc (30sec would be good)

  5. check if the feature has been applied successfully, do not get inside HIVE-shell in a box. Use the send command button in HiveOS web interface while the rig worker is selected.
    type in:
    ethtool -k eth0
    NOTE: -k must be small letter k

When the return message comes out, click on the blue text for “ethtool -k eth0”.

Then a new window shows up and the output should say this.

I think if you completely reinstall HiveOS, you have to redo this…

Happy mining!


Thanks for sharing this info!!!

Your directions have to enter this code “post-up ethtool -K tso off gso off” and it didn’t work, then I noticed in your screenshot that there needs to be “eth0” after the “-K” and now it works. Could you update your post? Spent about an hour trying to figure out why the segmentation was still “ON” THANKS!!!

sorry. maybe ot but…have anyone experienced pci e slots blackout? my board is booting up and bios is ok, but it shows red on all slots in bios identifier, if i disconnect gpu/gpus, it shows that nothing is connected…not red. any ideas??
I have another same board running with 10gpus atm with stock bios settings…

I updated the post, sorry about that.

1 Like

This is a glitch with Asrock H110, this happens to 3 of my boards, random PCIE blackout, not all slots at once, but just 1 or 2. It gets fixed if I move one of the risers to another slot and restart (move it only when the PC is de-energized)

1 Like

thanks, i was quite lost and tried everything, flashed mb bios, measured psu output to mb etc. the i accidentally tried with only one riser connected and all pcie´s came back alive. Whoh…i was sure that the board was fried. Good to know that is a h110 feature not a serious issue.

Many thanks!!!
I had same issue since I added one more GPU on my h110.

I managed to connect 10 gpu+s with stock bios settings…stable and no issues. really happy after all the trouble with this board, all gpus are on pci 1x slots, not using x16. happy days:)


I have 6 rigs with H110 and it does that every once in a while. Especially with AMD GPU. It mines really well with nVidia. So I don’t know the fix, but I just restart(30 sec) and it usually fixes itself. I use a WIFI power switch to reboot when I’m away.

1 Like

UPDATE: Even after this solution, I still get “Network constipation” sometimes, but the times between the glitch is longer, so it is a semi-fix…

I had a “network constipation” yesterday, after 3 weeks of run time, I had to restart my internet modem.

i wonder what is the case of this.I had this issue week ago like every day for a week, and now without issus since. Is it related to home network of the mirror that is in use…firewall rules if any…or is it just another feature of this mb…like pci black out´s…well, for now the board is again cooperating so happy days.

This is the first time I have heard of this issue, I have 3 rigs all running the Asrock H110 Pro BTC+ mobo and I have never faced this issue. I checked using ethtool -k eth0 and both tcp-segmentation and generic-segmentation are on.

Mine locked up my LAN twice again today after these “changes” so I’m not entirely sure that they do anything. It was running fine for almost a week and I can’t ever seem to find the problem in any error logs. FWIW I have 7 cards installed all using the white PCIEx1 ports since I don’t have enough yet to build out the full 12 rig my setup can handle. I also run from a sata SSD. I’ve been wanting to move this all to my office but can’t have my business LAN randomly get locked up like this… Will keep trying to figure this out because it’s extremely annoying. When this happens and my LAN gets locked up, WLAN still works. 5 seconds after I hit the reset switch on my mobo all WLAN instantly starts working again.

what bios version are you on?

The lastest for the board which is 1.60 I believe.

Now all the sudden i have started to get this issue, (too high oc, dead gpu error etc) and the worker goes offline and get stuck, no internet connection from the board, so its not rebooting. Sometimes if it reboot, board go straight to bios. I have flash board to 1.6 bios. Board bios settings are mostly default, only power on,audio and sata disabled. In boot options is have uefi and usb.
Really bad issu…miner have been offlineseveral times for a day or so without me knowing anything…
Il look into yor solution and give it a try. Thanks for posting

If your board goes straight to bios it seems your Hive OS is not booting.

Could either be your actual hdd/SSD/usb drive you’ve installed Hive on or could be a corrupt Hive installation.

Try a new hive install from scratch and see if it boots


So glad that we have here people with deeper understanding about hive os!
U are a champion :sunglasses:
This issue heave been a pain in da ass for long…i followed your guide and bang! all went like it should, now its showing that the issue fixed.
Havent had any reboots since fix so i actually dont know does it work, but im 100% that its fine now.
Thanks for sharing this info and for writing a good guide for how to do it.

Edit# Yesterday when i had to reboot several times things were going smoothly,no issues but just now, bot rigs crashed and went offline when rebooting. I check´d with ethtool the status, for me it looks like it all good. Can there be another reason for this behaviour for rig´s when rebooting?