Increase your income with Hive. Invite your friends and earn real cryptocurrency!

AsRock Z590 Phantom Gaming 4/ac won't work with 3 GPUs

Hi freinds, I have the AsRock Z590 Phantom Gaming 4/ac motherboard paired with an i3-10100. The motherboard is working fine with 2 cards. However, whenever I tried to plug in 3 cards, only 1 card would be recogized and could start mining while the other two cards will show up but are kinda unrecoginized

i also checked amd-info and I got the error Cannot find DRI instance at PCI xxxxx.

i tried removed OC, enabled above 4G encoding, disabled CSM, set PCIE to gen 2 but they all did not work.

I tried to also put some cards on the x16 slots directly but it’s the same

Edit: all 3 or 4 cards are recognized in windows, and I also tried minerstat OS and all 4 cards are recognized and are mining. I still want to use hiveOS tho if that’s possible

Thank you for reading and could you please give me some advice on how I can fix it.

Which version of the HiveOs you have?

It’s the latest from hiveOS install page. 1104? I also tried to update when the system reminds me there is an update. Now it’s at 0.6-211@211116

Yes I have the exact same problem. Only 1 card can be recognized in HiveOS. I bought the Z590 Phantom Gaming for its 5 PCIE slots, which appear to be useless for now. I’m able to get the cards recognized in Windows but they are not mining stably. Random card just goes 20-30 GH/s then the rig is disconnected from the pool. Thank you for the information I will try MinerstatOS this weekend. As long as it works I don’t mind which system it is.

all my 5 AMD 6600 are mining stably in minerstat OS. I wanted to switch to hiveOS because I want to have both Nvidia and AMD running in the same rig. But I guess i’ll stay with AMD for now if this is not resolved

Great news for me as I have 6600xts. HiveOS is good to use but they may have some adaption issue with Z590 Phantom Gaming. It’s a relatively new board and not among the most popular ones. Are you using its wifi module? I’m a bit concerned that it may take up some PCIE lanes as it’s a M.2 card fixed on the board.

Yes i’m using the WiFi. The thing is if windows and minerstat OS (also linux based) could work with 5 cards, why can’t hiveOS work with 5 cards too?

My understand is that these OS all need to work with the motherboard. Windows has pre-loaded drivers for the MB or you can update from ASrock, Minerstat OS may also have the right driver installed. But HiveOS may lack the specific driver for this board, which means the board cannot function properly in HiveOS. Afterall they are all separate systems with their own software environment.

Same cases with mine.

Have 5 AMD Cards to test out, only one can work.

I gave up this board already.

Buenas me prodrias enviar la configuracion que usaste para que te reconozca en windows 4 gpu. Gracias.

Disable 4G encoding. I was able to get 2 cards working that way. But not with 3. The board is a piece of ass.

This might help someone trying to get this motherboard working

You need to change this settings

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.