Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Asrock h81 pro btc+ no video

I have added a new worker with a asrock h81 pro btc+ with a xeon cpu e3-1226 v3 and 6 gpus. During the initial boot I have video but in the second stage of the boot I have nothing just a blank screen. I have managed to log in just on pure speculation on what stage the boot was at. Anyhow the miner is running on the web panel but I still have no video on the display. I would assume this is a driver issue.

1 Like

plug the display into a gpu

non input gpu cards

I have this same problem since the weekend. After researching some new algorithms I knew I needed to update my drivers, I was on kernel 510 and older AMD and Nvidia. Same board, ASRock H81 Pro BTC+. Used hive-replace which has worked fine on other rigs, but with this system of 5700XTs, I have video (as you say you do) during 1st stage of boot, but once mining begins, black screen. The system is working fine, I can access everything remote, it just is not putting out video from the onboard graphics except for first stage of boot, where everything streams across the screen. Once mining starts, black screen. I tried both the VGA and HDMI ports. I was going to run hive-replace again to see if that would fix it, or if not, just re-burn the drive or make another one. But thought I would search forum first.

Exactly. I spent many hours trying the limited bios that are available and landed on bios ver 1.3b which is not uefi. I originally had 1.2 which worked but had the problem of no video. Tried 1.4 but does not have 4g decode (support for more than 4 gpus) which 1.2 does but can’t be enabled or disabled. 1.3 has the ability to enable disable CSM and 4g decode but again not uefi. So none of the bios’s available are an ideal option.

Also reburning does not work neither as I tried that to.

I actually had that issue with my rx 5700 xt, which would not display when plugged into my rig. I had another display card, but it wouldnt display with the 5700 xt plugged in. Card worked fine in a normal computer, but I could never get display from my mining rig. i have a 3070 now and it displays just fine.

I’m going to send a ticket in to ASRock. Can’t hurt. They designed this board to mine, plenty of people still using it. I can’t believe that updating the Hive kernel caused such an annoying issue.

Here’s the temporary but maybe permanent solution I found. I went back to kernel 510 and the accompanying drivers. Fault lies in the software somehow, video from both ports fine until a certain point in the boot. Motherboard is getting a command to change something, right before mining starts. Rig works absolutely fine otherwise. As long as no issues, I just manage remote. But sometimes you need a monitor hooked up, as I do with this rig. For me it was easy, the USB drive I upgraded from to SSD was in the same drawer I put it back in December. Took the thing a little longer to load, but picked up right where the other one left off before I ran hive-replace -s -y. It worked flawlessly on 3 other rigs, 1 Nvidia, 2 AMDs, but if I run it again, I’m not doing the “-y” option. This forces “yes” to the prompts. Maybe I can figure out what’s going on during the update. Rig came up on kawpow, tuned where I left it off Definitely going to have to cut back on those settings.

Yeah, I have a different motherboard but still had that issue. I really think It might have something to do with amd drivers, since my 3070 works just fine. My 1070 also never had any issues, so maybe just an amd thing.