More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

ASRock H510 not recognised Nvidia and Amd card

Hi, I have an ASRock H510 PRO BTC+, I’m mining with 3 Amd Rx580 and all works good.
I bought 2 Nvidia 1660Ti, i tried to make all the 5 gpus work together, but the Nvidia cards were not recognised.

All the connections are good, all the cards work fine.

I put only the two Nvidia cards on the rig, the first work fine, the second isn’t recognised( HiveOs show me the name but it doesn’t understand that is an Nvidia card,so it doesn’t work).
I disabled the “above 4G decoding” and put all the PCIe to gen2, now the two Nvidia cards work.
But if i try to add an Amd card the bios return to the default configuration and it enable “above 4G decoding” and the second Nvidia card is still not recognised.

How can i resolve this problem? Is it possible to run 3 Amd cards and 2 Nvidia Cards together on ASRock H510?

have you done all of these? https://hiveon.com/knowledge-base/troubleshooting/mb_setup/

Hi, I resolve the problem by enabling C.A.M (Clever access memory) in the bios.
With this I can add many Nvidia GPU and Amd GPU without problems.
The “above 4G decoding” has to be enable.

1 Like