Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Asrock H470 - Issue with RTX 3070 & 1660 Super working together

I have a Asrock Steel legend H470 MB. 16gb ram, 2 EVGA 800 watt power supply

2 x Asus Tuf RTX 3070
Saphire 5700XT
Asus Dual 1660 Super

The 3070, and the 5700xt were running perfect in Hive OS. Had a few weeks of uptime with 0 issues. Finally got a 1660 Super, so tried to add it to the rig. At First, the rig would not post.

I tried 4G Decoding enabled, and all the other suggestions i could find. ( Disabled all aspm, VT-d Disabled, PCIE speeds 2x, boot option is not UEFI. Finally i did a bios update on motherboard, and now it would post, and boot into HiveOS.

All the cards are on 1x risers on the motherboard. When i add the 1660 super, the 3070 is detected by hive, but it will not mine. It also does not list memory information. drive or power. I just get the Gefore RTX 3070 in green, but no info in grey below it. As soon as i remove the 1660 super, the 3070 and 5700xt work perfect again.

I can add the 1660 super with the 5700xt, and remove the 3070, and everything works perfect. I tried to have the 1660 super installed in the motherboard 16x slot, and also tried the 3070 in the motherboard. When the 1660 super is in the motherboard, the 3070 will appear, but not minable, and no information shows for the card. When the 3070 is in the motherboard and i add the 1660 super HiveOS will start loading, but hangs and never finished booting. No errors that i see. I can get 2 3070’s and the 5700xt working perfect, so it shouldn’t be a 3 card or power issue.

i had everything on an EVGA 800w power supply which should be plenty, but i did add a second 800w power supply, and have the same issue.

For some reason the 1660 super and the 3070 do not want to work in the same rig and i cannot figure out why. If i try just the 2 cards, i have the same issue. With the 1660 super is installed, the 3070 does not load. Is this some weird drive issue, or something possible? i am on the latest stable HiveOS using LOLminer.