Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Anybody know why my 4x Vega rig seems to be hardcapped with maximum hash rate?

Hola me amigos. So I’m running a rig with 4 powercolor vega 56 gpus mining ethash on Teamredminer and it seems that no matter what I do in regards to oc, undervolting, vbios swaps, drivers, etc… I cannot break 38.2 Mh/s. Can anyone offer up any knowledge as to why that might be? I’m a noob to mining and have been mining on TRM for the last two months. Thanks everyone.

FWIW, my vegas are powered by a 1200 watt HDX psu and the motherboardboard and cpu are running off their own 750 watt psu independently. shitty chinese risers on every gpu. drivers have bee amdgpu-pro and while I’ve tried several versions, they are currently on 19.10 (didn’t see any difference in hashrate or stability while running 19.50, 19.30, etc.

Thanks for the help

I know this is quite a few months old, but what overclocking settings have you used? Were you able to resolve your issue? I’m in the process over overclock/undervolting the two Sapphire Pulse Vega 56 I have. The only thing that seemed to work for me was increasing the memory clock. Increasing the memory clock to 950 Mhz was able to get me up from 34.7 to 41.6 Mh/s (ethash). Bumping up the core clock didn’t appear to help, but to only introduce instability. I also reduced the power limit from 180 W to 140 W, but somehow that translates to over 120 W at the wall (monitored with a Kill-A-Watt).

i was having issues with my vega 64 it was not getting amd-oc correctly so i did that

echo "" >> /hive/etc/crontab.root; echo -e "*/5 * * * * /hive/sbin/amd-oc \n" >> /hive/etc/crontab.root

to get it amd-oc every 5 min. It was then working fine however need to be reapplied everytime you upgrade the hiveos version. (if you have hashrate watchdog use somehing like 6 min restart miner 10 min restart rig.

for good stats you also need to amd-mem-tweak it : i recommend adding it to /home/user/ and to enable GUI on the rig.

1 Like

On a vega 56 do this for near 47 mh/s rate:

Memory clock at 950 mhz (yes even if you have hynix memory. I have a large quantity of samsung as well as hynix reference cards working at this frequency just fine).

Turn your core voltage down to 835mv and your core clock to 1000 mhz. Throw in your own favorite amdmemtweak settings (–CL 18 --RCDRD 12 --REF 15000 for samsung and --cl 18 --ras 23 --rcdrd 22 --rcdwr 11 --rc 34 --rp 13 --rrds 3 --rrdl 4 --rtp 6 --faw 12 --cwl 7 --wtrs 4 --wtrl 4 --wr 11 --rfc 164 --REF 15000 for hynix memory)

If you’re running hive either off of the vega image or the beta, it doesn’t really seem to matter including their different 19.10 and 19.30 drivers respectively; so have faith and remember to apply aggressive undervolting AFTER you have applied and hive has completed your oc settings.

Now start your miner and with AU now applied you will most likely your vega tach lights (for reference card models) will show 3 steady red lights instead of the full five. This is what i run and its by far the best quality of hashing (i have 4000 accepted shares for every 1 invalid share), best reported hash rate and best compromise I’ve found for power draw since the fucking utility companies are what suck out most of our profits due to expensive electric rates.

Ive fucking scrapped, cried, broken shit, cried again, pathetically wallowed, wandered through at least one spiritual and one existential crisis all so i could share Ted’s secret stock Vega 56 parameters. I stand on the shoulders of the hiveos devs, the teamredminer devs and the coolest dude of all… the guy whose name i cannot remember that created andmemtweak and like a modern day Prometheus, decided to take his very valuable code and give it away for free. Its through his own example that I share my small amount of vega mining with the rest of you. Hash well and ill see you on the other side of Eth 2.0 where I’ll be running a Cardano stake pool and cheering for ethereums ultimate terminus.


6x Vega64 rig Getting 49-50mH/s Ethash

amdmemtweak --CL 22 --RAS 35 --RCDRD 16 --RCDWR 12 --RC 44 --RP 14 --RRDS 3 --RRDL 5 --RTP 5 --CWL 7 --WTRS 4 --WTRL 9 --WR 16 --WRRD 1 --RDWR 19 --MRD 8 --MOD 15 --PD 8 --CKSRE 10 --CKSRX 10 --RFC 247 --REF 10000

1000 900/850 1100

That being said they start and get stuck at 7Mh/s until i change something which is annoying

1 Like

same shit here, the difference is that i can not get them do else than 7mhs, does not matter what i change.
amd-oc is screwed since i made a stupid move and updated from a 2018 image to a new one. since than my 288mhs dropped to 202-228mhs max, with rebooting every hour. as i currently can not access the rig phisically, i was not able to roll back to an older image, even with hive-replace --list the option with the old vega img has a broken link and hiveos support is not able to provide a link for [email protected] now for a month.

any idea how to get the oc fixed with phoenixminer?

this real help me ( teamredminer/ETHASH_TUNING_GUIDE.txt at 0.8.0 · todxx/teamredminer · GitHub )

Vega 56 Hynix Stock-to-Performance Guide (A-mode)

The Vega 56 GPUs with Hynix HBM2 memory are generally known to be
underperforming their Samsung siblings. With TRM, they can often reach 50 MH/s.

The tuning setup we have come to like in our tests is the following:

  1. Start with your core clk at 1100 MHz while pushing the mem clock to 950
    MHz. If you know that your mem can’t handle 950 MHz, lower it from the
    start. Use 875mV for voltage.

  2. Start with the following modded mem timings as a baseline:

    –cl 18 --ras 23 --rcdrd 23 --rcdwr 11 --rc 34 --rp 13
    –rrds 3 --rrdl 4 --rtp 6 --faw 12 --cwl 7 --wtrs 4 --wtrl 4
    –wr 11 --rfc 164 --REF 17000

  3. The guess is that this setup will hit 46-46.5 MH/s for you. The key to
    improving performance is --rcdrd. Proceed to lower that value one step at the
    time, stopping and restarting the miner between each change. You must be on
    the lookout for hw errors which means you’ve reached your GPU’s limit.

  4. If you’re part of the lucky crowd and your GPU can handle a rcdrd value as
    low as 15-16, you should now be seeing a 50-50.2 MH/s hashrate. If your card
    starts producing hw errors, you need to increase rcdrd until you’re
    stable. NOTE: you must blast your fans to make sure the HBM temp is kept in
    check. You should always monitor the gpu mem temp as displayed by TRM in the
    stats output. You can also use the TRM built-in fan control to target a
    specific mem temp, see USAGE.txt for info on how to use --fan_control.

  5. Lower the core clk as much as possible without losing hashrate. If you ended
    up ith a rcdrd value > 16, there should be room to lower it from 1100
    MHz. For a 50 MH/s hashrate, you probably need the 1100 MHz core clk to
    sustain it.

  6. Lower voltage to 850/840/830/820 mV, as low as possible while
    remaining stable.

  7. For better efficency (but lower hashrate), tune down your core clk
    and try to further lower the voltage.

  8. See the separate part for B-mode below for a potential additional power save.

Using this setup, we have been running Gigabyte Vega 56 Hynix cards for > 50
MH/s with no hw errors.

Hello, can you tell me what you change when your cards get stuck at 7MH/s ? I ran into same problem, after applying OC my Vega64 MemMhz drops to 167Mhz, and mine at 7MH/s.

I have a vega 56 and when I put it first time it had vega 64 bios and it was making 7mh so i just flashed to his own bios. Idk if that could be the problem.

Need to use amdmemtweak

I have same problem, hash stuck around 8mH and memMHz at 167 , i find this page talking about this problem it is some how related to the kernal destribution.

i think hiveos devolper team need to look at it

I’ve run into a similar problem. I have 4 vega 64’s that will OC if they’re the only cards, however if I add a vega 56 or rx 580 to the mix and overclock those the rest of the vegas come up dead. If I clear the overclock, I can only OC one card and the rest of the cards hard cap at 33mh/s.

It’s very bizarre.

had the same problem while playing with values - if you go above 960, you need to stop teamredminer (miner stop) before you apply the new settings. Then start mining again with “miner start” and watch the output.

I think the problem is related to teamredminer when it is already running.

check out this thread in the forum - alot of help here.