Increase your income with Hive. Invite your friends and earn real cryptocurrency!

[amdmemtweak] Polaris & Vega Optimisation [Support][Settings]

This thread is going to be dedicated to helping people set up and share working settings for amdmemtweak. This application is now included as apart of HiveOS, so it’s fitting to have a thread here where we try to figure out be settings. I will be experimenting with this program; my goal is to get a working optimisation for Polaris cards.

Amdmemtweak is a program that allows you to change memory timings on the fly.

This application is open source and originally developed by Eliovp.

[Manually Compile Instuctions]

 git clone
 cd amdmemorytweak/linux
 sudo apt-get install build-essential -y
 sudo apt-get install libpci-dev -y 
 sudo apt-get update -y
 g++ AmdMemTweak.cpp -lpci -lresolv -o amdmemtweak
 rm /hive/sbin/amdmemtweak
 mv /home/user/amdmemorytweak/linux/amdmemtweak /hive/sbin/

Link: Github

Get current settings

amdmemtweak --current


GPU 0:  Ellesmere [Radeon RX 470/480/570/570X/580/580X] pci:0000:01:00.0
PMG:      CKSRE: 2        CKSRX: 2        CKE_PULSE: 12   CKE: 12         SEQ_IDLE: 7
CAS:      CL: 21          W2R: 14         R2R: 5          CCLD: 4         R2W: 28         NOPR: 0         NOPW: 0
RAS:      RC: 70          RRD: 5          RCDRA: 25       RCDR: 25        RCDWA: 14       RCDW: 14
MISC:     RFC: 150        TRP: 27         RP_RDA: 26      RP_WRA: 50
MISC2:    WDATATR: 0      T32AW: 0        CRCWL: 25       CRCRL: 3        FAW: 0          PA2WDATA: 0     PA2RDATA: 0
M3(MR4):          RAS: 0
DRAM1:    RASMACTWR: 34   RASMACTRD: 27   ACTWR: 9        ACTRD: 9
DRAM2:    RAS2RAS: 101    RP: 26          WRPLUSRP: 30    BUS_TURN: 13

Getting current settings is useful as a reference.

Reported working settings:

sapphire vega56 pulse hynix flashed with nitro vega 64 bios.
gpu-z clocks and voltages are 1280/[email protected]
trtl: 19.27 kh/s with teamread

amdmemtweak --RC 45 --rcdrd 12 --rcdwr 5 --rp 13 --faw 16

Powercolor Vega 64 on latest Adrenalin 19.3.3 drivers.

amdmemtweak --CL 16 --RAS 30 --RCDRD 14 --RCDWR 14 --RC 44 --RP 14s --RRDS 3 --RRDL 5 --RTP 5 --FAW 20 --CWL 7 --WTRS 4 --WTRL 9 --WR 16 --WRRD 1 --RDWR 19 --REF 17550 --MRD 8 --MOD 15 --PD 8 --CKSRE 10 --CKSRX 10 --RFC 244

Vega 64 air cooled (MSI air boost OC w/ samsung mem)
hashrate w/ stock timings: ~19.5kh/s
hashrate w/ new timings: 21.36kh/s

amdmemtweak --rp 10 --rc 44 --rfc 300 --rrd 3 --rcdrd 12 --rcdwr 5

vega 64 Cryptonight litev7
Stock Timing : 4530 h/s
Todxx Timing : 4800 h/s

amdmemtweak --rp 10 --rc 44 --rfc 300 --rrd 3 --rcdrd 12 --rcdwr 5

How have you been able to enable this in HiveOS? Thank you for the help!
–Immediate update… Update HiveOS and it is available! Nice.


Please share your result and what cards are you running?

Before I compile it from Git, where is it in Hive? I saw it was listed as part of the last update, but there aren’t any new settings available in the GUI as far as I can tell.

I guess, could you explain how you start or enable amdmemtweak from the GUI instead of having to shell in, or maybe that isn’t a thing yet?

I have 3x Vega 56 cards, by the way


Answering my own question here, you can either type/paste the command into the Run Command popup from the menu icons in hiveOS Gui web interface, or enter it into a shell session. These settings didn’t help me with stock Vega 56 cards

The location is below


However I get an error I get when trying to run it

/hive/sbin/amdmemtweak: /lib/x86_64-linux-gnu/ version `LIBPCI_3.5' not found (required by /hive/sbin/amdmemtweak)

The one that I compile manually seems to work just fine

[email protected]:/# /home/user/amdmemorytweak/linux/amdmemtweak --rc 10                                                                       
Successfully applied new RC settings to GPU 0.                                                                                              
Successfully applied new RC settings to GPU 1.                                                                                              
Successfully applied new RC settings to GPU 2.                                                                                              
Successfully applied new RC settings to GPU 3.                                                                                              
Successfully applied new RC settings to GPU 4.                                                                                              
Successfully applied new RC settings to GPU 5.                                                                                              
Successfully applied new RC settings to GPU 6.

They won’t add this into the GUI until this software becomes better.
It’s still very early and buggy for sure. We only on version 0.1.7
in due time :grinning:

I fixed my error by removing

rm /hive/sbin/amdmemtweak

And replacing it with the freshly compiled one

mv /home/user/amdmemorytweak/linux/amdmemtweak /hive/sbin/
1 Like

IS there a script/batch option to run your tweak settings after the rig starts? I’ve been very pleased with my AMD Rig with the exception of the last few days. I normally do 205MH but lately, the rigs lose 55% hash rate after running for a while. It’s driving me nuts and I’ve tried so many thigs but cant seem to resolve this new issue of losing hash rate. Also, it doesn’t matter what ethash miner I use. Any suggestions?

Have you tried any tweaks for ETH?

You should be able to run the AMD tweak on startup by adding them to the
Just add the command you run to the end of the rc.local file.
So in this situation it’s amdmemtweak --settings.

I’ve been trying to get performance gain with polaris cards but if your cards are already modded then the gain you can get from running this on RX cards is minimal.
With Vega though you can get a lot of gain. More so on XMR than ETH

If you need any further help with getting it to apply on start up let me know

Hi, how did you get to ride the RX Vega together with the RX 580?

Did you have a different configuration?


I have a question and it’s off topic )))
Do you have mixed rig with Vega and RX580?
Does it work steadily? Is it possible to apply amdmemtweak separately to Vega cards?
What image of HiveOS is used for rig - special, for Vega?


I just added REF 17000 to overclock in GUI and got 8% extra. Even if you can get some % extra with all the advanced CLI parameters this was a very good bang for the buck.

Vega 64 on CN-R now 2.24 (undervolt 186 watt)

I am also curious about the vega RX mix. Might be the reason he has problems =) but i would also b e possible the the new amd drivers (now Open GL, same as Vega version) would work on both. will test later this week.

1 Like

Just installed [email protected] and it works with vega. At least last 1 hour. But this RIG is only vega64. no mix.

Does your rig have an RX?

1 Like

Yes. Now its mixed. RX580, Vega 64 and GTX 1660 Ti. Works perfect and stable. But had to lower the overclocking on RX to get it stable.

Login with SSH or “Hive shell start” and update to latest GPU drivers with the command:
hive-replace -y[email protected]
(find the URL to newest release here:

If you have any issues remove all overclocking and start with stock settings.

1 Like

Autofan is not working on the Vega.
But it is stable. I have issues with OC but not shure if it is because of the mix…
Undervolting works, but i get lower hashrates.