Increase your income with Hive. Invite your friends and earn real cryptocurrency!

AMD and Nvidia on same rig not working

I have a mining rig with 5 - RX 580 and 5 - GTX 1660 TI. I am running HiveOS and all the cards are recognized in the OS. The problem is the AMD cards are running and the nvidia cards are not. I am using Phoenixminer and have also tried with lolminer.


Asrock H110
850 Watt modular
2 - 1200 HP Server PSU

1 Like

What Kernel and OS?

I thing you should upgrate you ram in your system (8 gb) and then upgrate to the latest stable version of Hive OS)

OS version: 0.6-199@210218


All of the GPUs have gone down now. They are all showing up in hiveos but not hashing. I have multiple machines and haven’t seen this with any of the other rigs.

You are running the right version kernel and OS. Phoenix miner should have no issues with the mixed cards. I have a rig with 7 5700xt and 6 3080 that runs real smooth. I agree that I would bump up the systems ram. I run 16GB on all of my rigs, while running they show that I have 11GB available, so it is using more than 4.

It looks like you have enough power to run the rig. Are the HP’s only running the GPU’s, and SATA for the associated card?

Have you done anything with the OC, or VBIOS? Your drawing a ton of power for the hashrate you have. Is it safe to assume you are mining ETH?

I just put my first nvidia card next to my 11 amd.
In theory lolminer could handle both and phoenix too, butfor me neither do it.
So i made in 1 rig two miners. teamred for amds and lol for the nvidia one.

it runs quite good. except this “No cards available for OC!” if the rig restarts (unfortunately 1 of my card randomly restarts the rig every 1-2 days. then i need to turn off all oc for nvidia, and turn it back manually. if oc is on on startup, nvidia does not start

I have now installed 8GB of ram but it is showing that it still has 6.1GB available. I haven’t flashed the cards or over clocked yet. I’m just trying to get everything running before i fine tune everything.

Can you give me the power layout? PSU is doing the motherboard, sata, 2 GPU etc? Have you verified that the GPU risers are good? Have you attempted to run with 1 AMD card, then add the NVIDIA?
Anytime I make significant changes, I give it a new rig ID from Hiveos and start from there.

I have the same problem … any solution??

1 Like

Try checking out this how-to-guide: How to manage your mining farm with AMD and NVIDIA cards at the same time | Hive OS

Hi i stumbled upon your reply post here, I am having simlar issues but with only 5 cards, 1 of the card that can’t hash when a 5th card is enabled is my 2080TI, it reads as TU102 but when i disconnect one of my rx580 or a 1070gtx, the 2080 TI is able to mine again.

I’m thinking maybe its the ram you mentioned? becuase i’m running intel i3, 1600 PSU and 6gb of ram. DO you believe it can be the ram that is causing my issue ?

Have you experienced this with more than one mining program? Phoenix Miner, NBminer…

thanks for replying back Cerberus, i end up finding out what was wrong with my rig. I forgot to enable 4g Decoding =/, i really appreciate you replying back though!

Hope you get it working. Just trying to get my mixed rig to start hashing.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.